Chevy Nova Forum banner

1 - 20 of 33 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter #1
Other forums I belong to usually have an area to tell others what they did to their car that day without posting a new thread, I want to see if there is an intrest for such post? I will start.

This 63 wagon has sat since 1981, I pulled the valve covers to start spraying WD40 in the rockers lifter and such and removed the plugs to do the same to the cylinder, I want to get it ready and see if it will start in a few weeks.




 

·
Registered
Joined
·
542 Posts
just kinda tooled around in the vert this morning , went to the bank then the post office. scored a killer deal on a 350/700r4 gonna pick it up tonight.
 

·
Premium Member
Joined
·
182 Posts
My new wheels were delivered yesterday (3 weeks early!) Got them installed this morning along with the rocker molding.

 

·
Premium Member
Joined
·
182 Posts
Thanks Batman. Wheels are 17X7 4 3/4 backspacing. Tires are 215/45/17 all around. Ordered them from Newstalga Wheels. Stock rear end with Wilwood disk brakes and TCI pro tour front end. Looking at the fit I probably could have gone with 225. Once I get the car finished and drive it around, I'll have a better idea. After six years waiting to drive it,I doubt the first set of rear wheels is going to last very long:D
 

·
Registered
Joined
·
3,849 Posts
Wife and kids are off in Maui so I drove the 62 to bevmo and picked up five cases of wine I ordered online with the 5 cent sale. Even though the fam IS in Hawaii it felt like it HERE today. 85 degrees and 55% humidity. Very unusual for my part of town, Ventura County, Ca.

So thats ALL I did with the Nova today, some shopping. Great day for a drive though... JR
 

·
Registered
Joined
·
234 Posts
The vert does look awesome! But, yeah, that's the same size tire I'm running on my Nissan Versa.:D

On my first-gen part-out, I got the gas tank out and got the back bumper off today. Gas tank isn't rusted through!!! yippee!!! It still had 4 gallons of leaded regular in it, circa 1976! I'll be cleaning and painting it and putting it in my '64.
 

·
Registered
Joined
·
288 Posts
I put the alt. back in my car, then I mocked up the tailpipes on my buddy's 68 Nova... think I need to trim one side down some more... then I mocked up my new Summit digital tach/shift light before removing my gauge cluster to fix the broken pointer on the speedo... I used a cut down straw from a can of brake clean for the new pointer... still need to mount the heater control cables & MSD 6AL box...
 

·
Premium Member
Joined
·
6,582 Posts
Not my first gen but on a friends I finished up some wiring (Stereo) and took it out and drove it...:devil: he wasn't home and the speedo isn't working so he will never know how far I drove it.:devil::devil::devil:
 

·
Premium Member
Joined
·
6,365 Posts
Not my first gen but on a friends I finished up some wiring (Stereo) and took it out and drove it...:devil: he wasn't home and the speedo isn't working so he will never know how far I drove it.:devil::devil::devil:
Thank you, I really do appreciate it and would have rather been there instead of where I was:yes:
 

·
Registered
Joined
·
750 Posts
Finished up some wiring on the car, including the neutral safety switch on the B&M shifter and the gear indicator lighting. Next order of business is the backup tail lights and horn wiring. I'll get there one day. :D

Also looking into options for a wideband O2 sensor setup so I can start tuning this carb. Think I may go with an Innovate LM-2 system.
 
1 - 20 of 33 Posts
Top