Chevy Nova Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I am installing a TPI 305 from a '86 camaro does anyone have any tips or trick that you can share. GIVE ME YOUR 2 CENTS
 
I

·
Guest
Joined
·
0 Posts
I'll be doing the same, '88 305 TPI and 5 speed into 1986 GMC Safari van.

Main thing to consider is the wiring. There are reqally only three wires that are needed to run the TPI and engine, easy to connect, and the rest is getting the loom fitted to run the sensors and other stuff the original car had.

Also, the computer is set with the PROM to run the engine as it was in the other car, with the same rear gearing, trans, etc, so...you may have to do a custom PROM for the computer to match the parameters used in the new situation, but that isn't hard to do, or get done these days.

Fuel tank for EFI uses a 'sump" sort of system, so the EFI pump inside the fuel tank doesn't go dry, you will need to address that as well.

Best advice is, make the engine think it's still in the 1986 Camaro.
 

·
Registered
Joined
·
26 Posts
tpi

i have done two of these. one in my 66 nova and another in my wife's 80 malibu. timeconsuming but not that difficult. i used the factory wiring harness and computer. also installed a 700r4 transmission. with a slight modification the rear trans mount will work. if you use mass air flow sensor,you will also need a speed sensor. i could write pages,but if you have any questions i may can answer call me at 864 682 2204 or email at [email protected].:yes:
 
1 - 3 of 3 Posts
Top