Chevy Nova Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hi i am a brand new proud owner of a 76 nova ss
and I was starting it up earlier and I notice that when I shut it back off
and I walked over to the engine I can hear a ticking noise coming from the right valve cover
Like something is barely tapping it
What is this?
is it bad?
but when the engine's running I cant hear it?
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
of what the car lol
I will take some tomorrow and put them on
its alittle rough but not too bad
 

·
Registered
Joined
·
222 Posts
One man's junk is another mans treasure. We are just happy to see another 4th gen join in!:cool:
 

·
Registered
Joined
·
12 Posts
Discussion Starter #7
Haha
Thanks I really love it.
it sounds like a mother ****er,
but its slow even though it has a 383 stroker in it,
It miss-fires and cuts out bad At high RPMS,
I thinks it needs a major tune up bad, like real bad.
Im changing the air filter and spark plugs tommorow
The air filter is horribly cloged like its gray and black (originally white)
Do you think that those problems would make a 383 stroker
really slow.
like its slower then a v6 camaro by alot.
I Will tell you the improvements that my seat dyno feels tomorrow.
 

·
Registered
Joined
·
222 Posts
Sounds like a good start, maybe throw a cap and rotor in it too. Make sure none of the plug wires are laying on the exhaust. That will burn a hole in them quicklike.
 
1 - 10 of 10 Posts
Top