Chevy Nova Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
I have looked through many forums but not quite seen the issue I'm having......

I hook the detent cable in at the trans. The cable at the carb side stays pushed out from the sleeve really far. I can pull it even farther and it retracts back to the same position. But it won't go back into the sleeve if its connected at the trans. here's a pic of its resting position....it can pull out farther but NOT retract any....

Any help is EXTREMELY appreciated!
 

Attachments

·
Registered
Joined
·
422 Posts
Not too sure, could be a stretched cable or have something to do with the routing/mounting. I used a Lokar throttle cable/bracket kit with their adjustable kickdown cable on my TH350/1406 combo and it was easy to set up and worked great. I also routed my cable up and over from the passenger side of the transmission.
 

·
Premium Member
1968 Chevy II Nova, Central Arkansas
Joined
·
2,015 Posts
I can't tell where your cable is going. I used a Lokar set up on mine but your stock one should be set up the same way.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #4
I’m wondering if it isn’t a mounting issue......I’m using this universal bracket that doesn’t give a specific mounting point, I’m gonna try a different bracket and if it still doesn’t work maybe try the lokar you guys are running. Thanks for the replies!
 

·
Registered
Joined
·
28 Posts
Discussion Starter #5
When I adjust the kickdown cable, I'm pushing up tab on cable bracket, opening to WOT, pushing "D" button all the way down on bracket. However.....the instructions say it is adjusted properly when you can get no more travel from the detent cable at wot.....however, at WOT i can still pull on the cable for another 1/4" maybe..... Any help as to what I'm doing wrong? ....if anything?

Thanks!
 
1 - 6 of 6 Posts
Top