Chevy Nova Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
Just rebuilt a th 350 with the B&M rebuild kit,extra clutches,shift kit etc. and it wont shift into drive.I tested it on jackstands and 1st,2nd,and reverse all work but it wont shift into drive.I checked the vaccuum modulator and it seems ok(no vaccuum leaks etc.)I tried manually shifting and leaving it in drive but no shift ,even up to 4500 r.p.m...Any ideas as to what would cause this?I really dont want to pull the trans again.Thanks.
 

·
Premium Member
Joined
·
8,051 Posts
I'm no expert but I did have one that did that the govenor had a piece of dirt stuck in the weights. It wouldn't let the weights swing out and let the trans shift. Mine was used and had many hard miles on it.
 

·
Premium Member
Joined
·
4,125 Posts
How is the 1-2 upshift? Is it delayed and a little harsh? If so, your symptoms are indicative of a low or no vacuum signal to the modulator. Which port is your modulator hooked to? Are you sure there is vacuum to the modulator?
 

·
Registered
Joined
·
45 Posts
Discussion Starter #4
My modulator is hooked to full vaccuum (not ported).Is this correct?My 1-2 shift doesnt feel harsh or delayed.Thanks for any help you can offer.
 

·
Registered
Joined
·
123 Posts
It could be the control valve assy. stuck 2-3 valve or the gaskets mispositioned or installed wrong or leaking. Improper vacuum but you said you checked that. are check balls in the right spot all so.
 

·
Premium Member
Joined
·
4,125 Posts
It could be the control valve assy. stuck 2-3 valve or the gaskets mispositioned or installed wrong or leaking. Improper vacuum but you said you checked that. are check balls in the right spot all so.
If the vacuum is hooked up to full manifold vacuum, then I tend to agree with this. It's not impossible that your governor is stuck but it also controls upshift timing for 1-2. Another thing...Your kickdown could be stuck. Try unhooking your kickdown cable, push it in as far as it will go into the housing and drive around the block with it unhooked.

Chuck
 

·
Registered
Joined
·
45 Posts
Discussion Starter #7
Thanks guys,I'll get my Nova out tomorrow for a drive if it stops pouring rain.I just hope I don't have to tear the trans down too far (if at all)to resolve this.I followed the rebuild book to a "T"and an incorrectly installed piston seal or gasket would be a bummer.Ive only tested it on the stands so far .Thanks.
 
1 - 7 of 7 Posts
Top