Chevy Nova Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have R-N-D positions, but can't get to Park. I've disconnected the trans., and the problem is still there. It's a '62 Nova 194 cu in. w/Powerglide. Any ideas on the problem?
DSCN3057.JPG
DSCN3057.JPG
 

·
Registered
Joined
·
36 Posts
Just for clarification... You disconnected the column shifter from the powerglide, but the column shift selector won't go up into park?
 

·
Vendor
Joined
·
1,760 Posts
Has the column been apart recently? Is the selector arm at the bottom of the column hitting anything? May take two people to check.

Not to hijack the thread, but let's get some pics of the car! Looks fantastic. Is that the original interior?
 

·
Super Moderator
Joined
·
3,831 Posts
Man, that's a good looking '62 convertible! We want to see more of that car.

If you have disconnected the rod from the trans, and the trans goes through all the positions and goes into park, is the lever loose on the shaft going into the trans? That could account for a lot of play or not making it to park. If that's tight and the trans operates as it is supposed to from the trans, then either the rod length is wrong, the rod ends are worn out or gone, the lower level is hitting something as suggested or the problem is in the column. Check the gear selecting lever in the car without the rod attached to the lever on the lower column. Could be excessive wear or play with the tube in the column and the lever at the lower part of the column.

Good looking '62!
 
1 - 4 of 4 Posts
Top