Chevy Nova Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
90 Posts
Discussion Starter #1
63 with 194 CI
Just put a new speedometer in tonite (OER) factory repro because old one was
screamin like a Banshee. New one is quiet but bounces like crazy all over the place. I assume it needs a new speedo cable now? Got to be right?
 

·
Registered
Joined
·
11 Posts
I replaced my whole dash cluster one made alot of noise and bounced around everywhere, one was quite but speed was about 5mph off, and another bounces a touch, it's quite, and speed is right but all were tested with the same cable.
 

·
Registered
Joined
·
334 Posts
Please let me know how it works out. Mine is bouncing like crazy, without noise, but the cable's rubber housing is cracked and barely is going into the Muncie.

Can't the cable get lubed, too? And if so did you try that?

-Rusty
 

·
Registered
Joined
·
2,449 Posts
i wouldn't think it was the inner cable. if it was binding inside the outer cable it would break that inner cable. my call would be the speedo gear in the tranny.
 

·
Super Moderator
Joined
·
3,552 Posts
The cable housing wears, as does the cable itself. With a new cable (cheap) and a cleaned and lubricated housing, it should turn very freely. Also, if you can twist one end of the cable as much as a turn while holding the other end of the cable stopped, then it's the cable.

I've had success using graphite lube in the housing. No issues.
 

·
Registered
Joined
·
90 Posts
Discussion Starter #7
Speedo fixed!

Ok I removed the old speedo cable and black oil poured out . It seem OK tho, loose spun good pulled it out of the sleeve, looked ok went ahead and installed a new one (9.00 in stock at Autozone) and bingo.... quiet, steady done deal.:)
 

·
Registered
Joined
·
334 Posts
Great news!

Not in stock at my local Autozone, but ordered from Advance for a dollar more (and closer) in tomorrow. Hope to have your good luck!

-Rusty
 

·
Registered
Joined
·
10 Posts
I've got a bouncy speedo also and starting to get a bit of a clicking noise that sounds like it's behind the dash (most noticeable at very light cruise as the engine/exhaust is quieter)

Which one is right from Autozone as an example as they have a 63" and 83"? Both say they fit but 20" is a fair difference! Keen to try a new cable first (most common thing with a bouncing speedo). Plan on doing gauges down the track but there is a long list ahead of that!
 

·
Registered
Joined
·
334 Posts
got the 63 inch one and it fit my muncie, a bit tight but certainly not terrible. and...BOOM! kiss that bouncing needle buh-bye!

thought it might be too short since it goes on passenger's side but it worked out decent. checked the manual and found it was previously routed wrong under the dash.

here is the link, part # Y-804, it was 1$ more than Autozone but they should price match for you if you want.
https://shop.advanceautoparts.com/p/atp-speedometer-cable-y-804/5612381-P?searchTerm=speedometer+cable

-Rusty
 

·
Registered
Joined
·
4,062 Posts
John

most likely all that "black oil" may have been the trouble.

When that oil warms up --- it may have been getting "sticky or gummy" .


jim
 

·
Registered
Joined
·
90 Posts
Discussion Starter #12
Speed cable

Yea Jim someone prior to me I think tried to fix it by dumping oil down it. Oh and my old one measured 63"
 
1 - 12 of 12 Posts
Top