Chevy Nova Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,167 Posts
Discussion Starter #1

In the photo you can see the bolt boss removed on the intake port and the lump installed, on the top side of the intake ports it has a plug. with the lump in the way i cant get a smaller head bolt in... so the only thing i could think of is to get a screw in stud and stick a nut on the top of it, and instead of going with ARP screw in studs would going to a bolt supplier and getting the screw in studs be just as good? if so what torque should i give it? with the other bolts being 95 ft lbs of torque would the screw in studs get more torque? or should i just get all screw in studs? im just alittle confused about how to get this thing attached!!! and any help would be much appreciated!!!
 

·
Registered
Joined
·
1,243 Posts
Richard I sent you a PM. for the head Bolts which I forgot to ship with your head. But anyway When you get them just unscrew the pipe plugs in the top of the port. and torque to the same 95Lbs as the rest of the head bolts.
 

·
Registered
Joined
·
1,167 Posts
Discussion Starter #3
Hey Larry,
PM sent.
I again wanted to thank you for the work, everything looks great!
Delays Delays Delays with work, gf, kids, stupid truck, etc. im gonna drive myself nuts if i dont get to hear this thing fire up this year!!!
Thanks again Larry!
 

·
Registered
Joined
·
1,243 Posts
I know your delay's my motor has been siting on the stand for almost 3yrs now In a shed. But now that I have moved It's now where I can finaly work on everything.I hope to have this baby fired up before yrs end.
 
1 - 5 of 5 Posts
Top