Chevy Nova Forum banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
298 Posts
Discussion Starter #1
here are the symptoms.

1) As I turn the key, accessories position things are fine idiot lights come on as normal, but once it gets to ignition position, I get a 'click' and instantly lose all power. After this occurs I don't have power at all in any position unless I unhook and rehook up battery.

2) So I step out of the car, unhook battery and hook it back up. Even before I put the key in the car, when I open the door the idiot lights light up. When I shut the door, idiot lights go out. Now I'm back at step 1.

clearly the little interior light switch in the door jamp is energizing the loop to the idiot lights when I open the door. I also have two fuses out of the fuse box right now, radio, and tail lights.

all things seemed to be working fine earlier, I was simply trying to start my car and was cranking a few times when this first happend. I check fuses, then saw radio fuse blown, then also saw taillight fuse blown, so I removed them.

should I replace the fuses before I do anything else? I figured leaving them out would just disconnect those circuits and wouldn't effect anything else is that true or can missing fuses mess everything up?
 

·
Premium Member
Joined
·
298 Posts
Discussion Starter #3
#1 Rule about electrical....check your grounds

I checked voltage from the battery to the engine block....strong 12volts
I checked voltage from the battery to the body....4 volts.

Then I rememered....I never hooked the body wire back up from the negative termainal to the to the quarter panel.

Ooops! Problem solved.
 

·
Registered
Joined
·
1,151 Posts
You and me both, Flyer! :D
 
1 - 7 of 7 Posts
Top