Chevy Nova Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
187 Posts
Discussion Starter #1
Engine guru's, I need some help. I did a head swap earlier in the year and borrowed a set of Comp Pro Magnum 1.6 roller rockers. I had been running Comp magnum roller tip 1.52 rockers with my old heads due to spring limitations. Both sets gave me the sewing machine valve train noise. Well the friend that loaned me the rockers needed them for a motor he was building so I took them off, and put the old magnums on the new heads. I got lots of valve train noise, checked lash 3 times. It's not a clatter like a miss adjusted valve, just really loud. Not accepting this I figured I would order some new rockers. I got scorpion 1.6 rollers that seemed to be one of the quieter brands from what I read. Nope! Just as loud and now I am pulling my hair out. I needed .050 longer pushrods when switching to the new heads, but have checked each time I have changed rockers and my pushrod length is right. So at this point, what do I try next. I was thinking of just letting it run for a while to see if it shuts up a bit. Anyone have any thoughts.
 

·
Registered
Joined
·
188 Posts
You made sure the pushrods aren't hitting the pushrod head holes or the guide plates?
 

·
Registered
Joined
·
2,161 Posts
Replace them with stock rockers and see if the noise goes away. Aluminum heads (are you running aluminum heads?) and roller rockers make noise.
 

·
Registered
Joined
·
187 Posts
Discussion Starter #6
Clearance looks good, I will double check the pushrod guide plate interference. I may have to steal back those rockers. I would rather not though.

I will take another look tomorrow night.
 

·
Registered
Joined
·
1,030 Posts
What valve covers are you using? Maybe try a thicker valve cover to reduce noise.
 

·
Registered
Joined
·
188 Posts
What valve covers are you using? Maybe try a thicker valve cover to reduce noise.
Yeah I forgot about that mine were hitting the VC's one time. You can see the witness marks inside if that's happening. It was on the sides and I just loosened the VC bolts and shifted them over a bit and that fixed the problem. I run Scorpion 1.6/1.5 split rockers. I had to go with a +.1 pushrod to get the valve train geometry correct. Have no excessive noise with the Scorpions.
 

·
Registered
Joined
·
187 Posts
Discussion Starter #10
So, I veto'd the let it run BS, I Think I was just frustrated. Check my logic on this. My buddies 327 that has the pro magnums that were on my motor is in my garage. Since they are 1.6 and the scorpions that are on my motor are 1.6, would it be an issue to swap only 1 bank of rockers and check to make sure the noise goes away on that side. It is loud enough I should be able to tell easy enough. Also the rockers went on his motor on the corresponding valve they were on my motor (yes, I am a freak like that) so that should help since they were not making noise

Or is this just stupid?

Also, brodix ik180 heads, chrome VC, and before I touched anything, it sounded like a sewing machine. Everything looks like it clears, I am not hitting the VC, it's not that kind of noise.

Thanks everyone, also any reason I would need to run more than 1/2 turn lash which is what Lunati calls for with my hydraulic cam.
 

·
Registered
Joined
·
1,038 Posts
My guess is its the lifters and not the rockers. Lunati uses Morel lifters and they are noisy. Do a search on the internet for noisy Morel hydraulic lifters. A heavier gauge valve cover may knock some noise down, but I think those lifters need 3/4 to a full turn of preload on them and I forget, but I think it was 10/40 oil for best shot at being quiet. Don't take this as gospel, look it up. I had a set of them 5 years ago and a little rusty on the details.
 

·
Registered
Joined
·
3,601 Posts
X2 what Ray said! We had a set of morels and wound up sending them back as they bled down now matter how much preload.
Went with another co (johnson I think) and had zero issues.
While you look it up you will see about 10 different oil recommendations through the years.:yes:
 

·
Registered
Joined
·
187 Posts
Discussion Starter #13
I am running a hydraulic flat tappet cam, morels are roller right? Also, I only got the noise after removing the pro magnums. So I'm not sure but fairly certain it is a rocker issue.
 

·
Registered
Joined
·
188 Posts
20 hours of driving and 2 long nights in Reno all rolled into 50 hours still trying to get my bearings back:turn: If I read your OP straight - You installed the new heads with the friends 1.6 Pro Magnums and it ran fine. You then installed your 1.52 Magnums and noise started. Then you bought some 1.6 Scorpions and the noise still there. Right so far? Yeah, swap a bank of the 1.6 Pro Magnums that worked before back and see if they work again.
 

·
Registered
Joined
·
187 Posts
Discussion Starter #16
Yes, that is correct. That's what I am gonna do. I was trying to not steal his rockers since we are both trying keep our car budgets in line. I will keep you posted, trying to get out there tomorrow night.
 

·
Registered
Joined
·
187 Posts
Discussion Starter #19
Yes, hydraulic flat, it does not look like I am hitting anywhere, nor hitting the VC. Wife worked late tonight so I was on kid homework patrol. I will hopefully get out there tomorrow.
 

·
Registered
Joined
·
187 Posts
Discussion Starter #20
So, I swapped one side of the motors rockers and started it. Still loud, while I was looking for something to light my car on fire with, the comp side quieted down. So I continued to let it run for a bit and the scorpions quieted down too. I still think the comps are a little quieter, but I am going to get a second opinion before I decide which to keep on, though I am leaning towards the comp. Is it possible that any little wear on the pushrod tip could have been causing it? Nothing visible but that's all I've got. Like a lifter on a cam, and it had to spin a for a bit? I have no idea?

Next question, anyone see why my buddies stock head 327 with .530 lift solid flat cam would have issues running the scorpions? I don't want to pawn them off on him, but I am leaning towards keeping the comps. He is cool either way.

Thanks for all the help I had never had this happen before, usually you just get clatter till oil pressure gets up.

Whatever, I just want to drive my car.
 
1 - 20 of 24 Posts
Top