Chevy Nova Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
525 Posts
Discussion Starter #1
I cranked my car today and it's still vibrating and the throttle response Is not good.it will not get up to high rpm.it is backfiring horribly especially under acceleration.it has a ticking noise in the engine also.what could that be?there is an oil leak about 8" by 8" under the front of the engine(pan gasket,timing cover?) after it sits for no more than 5 min.there is also slot of smoke coming out where the manifold collector meets the exhaust.what could be wrong with my engine????
 

·
Registered
Joined
·
4,760 Posts
read your post from the other day :yes: sounds like it needs a tune up big time the ticking noise is probably a stuck or bad lifter the what color is the smoke ( gray or black ) if its gary thats water in the oil ( blown head gasket ) check the oil in it if it looks like lite chocolate milk then yesser blown head gasket the back fireing maybe from timing or something in the carb
 

·
Registered
Joined
·
525 Posts
Discussion Starter #3
the smoke is grey.it doesn't do it all the time just most(after it has been running for a minunite or so it starts).the oil is black and thick.the car has new plugs,points,rotor,condenser,cap.the car was running fine and started this the first time I cranked it one day.do you think it could just be giving up??or what could it be?
 

·
Registered
Joined
·
4,760 Posts
ah ha check your point gap ( dwell ) this is why its backfiring maybe not enough or to much i would change the oil & filter just to get fresh stuff going in there check your plugs to see if they are fouling check sparkplug wires too make sure they are ok. i dont think its giving up, it could be but lets not assume that. check your plugs like i said and tell us what they look like if they are black they are fouled if they are brownish tan thats a good sign if there white that means the motor is to lean and possibly detonating which is what we dont want, also see if they have any metal specs on them or if the ground strap has melted if this is the case then i would say the motor has gone byby
 
1 - 4 of 4 Posts
Top