Chevy Nova Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
149 Posts
Discussion Starter #1
i just coupled my engine and tranny together, i am running a 350 and a 2004r into my 63ss hardtop, when i installed my convertor i made sure that it went as far in as it could go , it clicked 2 times and i know its in there good, now my question is this, when i put the tranny in gear i am able to spin the convertor with my hand no matter what gear i am in, i feel dumb for asking but i want to make sure i didnt screw something up, when the convertor is all the way on is it supposed to spin no matter what and also there is a tad bit of play on the convertor as well is that normal? with it on the tranny and i grab the sides of the convertor it moves side to side just a tad but, anyhow you guys are some of the best tech guys so i leave this one to you, oh yeah, hopefully ill have it going for the nova mini nats so i can drive it there, thanks
 

·
Registered
Joined
·
3,308 Posts
Ok,

If what you are telling me is that the torque convertor is spinning in all the gears, did you happen to install the 3 bolts that go on the welded threaded bosses on the torque convertor that would connect the flywheel to the torque convertor?

By no means was that a put down because I myself have forgotten some of the simplest things. If I have torqued you off in anyway, I appologize for my actions. Let me explain. Today I was troubleshooting a "knocking" at the bottom end of my engine. During the start-up and sometimes during turning the engine off, I would hear this dreadfull sound and it sounded like a rod or a main going bad. Once I got it up on jack stands, I found that all 3 bolts to the torque convertor were loose and causing the "knocking" sound at low rpms. I thought that I had a rod or a main bearing going bad and looking forward to rebuilding the bottom end of my motor........not!!!

Hope this helps.

BTW, 66 Chevy II, 2-dr cedan, 355 cid, 200-4R transmission.

Dan
 

·
Registered
Joined
·
149 Posts
Discussion Starter #4
the transmission is not bolted up yet, ill do that tomorrow, i have a little bit of knowledge and i know that it needs to be bolted to the flexplate, i found my awnsers and i am good as far as the convertor goes, ill get you guys some pics of the car when i drop the motor in, thanks
 
1 - 4 of 4 Posts
Top