Chevy Nova Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
Got thru to GM tech today and turns out that some of the GM 290hp 350crate engines had some issues with the valve train clearances as assembled at the factory. Turns out the cam (L-82 with .460 lift) was pinching the valve seals and destroying them. Didn't do it on all engines but some had marginal clearance and as a result pinched the seals and ruined them.

I did confirm today that the oil in my engine was getting in from the valve area and not up thru the rings. If you know of anyone with this engine let them know about this. GM gave me part numbers for new springs, seals, etc. to fix the problem without pulling the heads. The best thing to do it to pull the heads and have them machined for extra clearance which is what the factory should have done to start with.
 

·
Premium Member
Joined
·
15,966 Posts
And who exactly did you talk too?

:confused::confused::confused:

AL
 

·
Premium Member
Joined
·
15,966 Posts
I'd more importantly be asking who is going to pay to fix it?
GM would pay for the installer for the repair, based on GM Hour book and area hour rate & supply all the parts & wearables. (Oil EXC) or the repair could be done at the dealer.

If did destroy the seals I find it hard to believe it did not damage retainers or even drop a valve.

The 350/290hp engine uses o-ring valve seals that are under the keeper in cased in the valve retainer. Not umbrella seals.




Al
 

·
Registered
Joined
·
45 Posts
Discussion Starter #5
Going to get a new set of heads I think. We have the big Bloomington Gold Vette show going on this weekend in town and I am going to search the swap meet area and see what I can find. The heads on the engine now are big chamber 76cc smog heads. Not the best for performance.

I talked with the GM Powertrain Center about the heads (1-866-453-4123) They were somewhat helpful but I am on my own for the repairs to the heads since the engine is just out of warranty. Would have been nice if they could have done something for me but with GM on the edge I can understand.

I had the 260hp crate engine in my other Nova a few years ago and it went 14.62 at 92mph with a basic 4 barrel and headers set up. I then put on a set of Vortec heads, with a mild cam and put in a 3.73 posi and it ran a 13.60 at 104mph. I never had any problems with that engine set up. That is why I was really surprised when I had issues with the 290hp crate.

Thanks for all the input guys. I still hope to get the car out to the track once I get all the problems ironed out.
 
1 - 5 of 5 Posts
Top