Chevy Nova Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Guys,
Found out recently that my turn signals are no longer flashing. I do have an aftermarket gauge cluster with turn signal indicators, which are working. The turn indicators outside will light when the stalk is moved either direction, so I thought the flasher module must be the problem. My problem, I can find the flasher! I do have an under dash vintage air system, so its not the easiest to see around, but I've looked everywhere and can't seem to locate the original can. From what I've been able to research on the forum, it should have originally around the ash tray area. IF anyone has a decent photo of where the original was mounted, or where they found theirs, please comment. I'm really getting tired of standing on my head under the dash! Thanks!
 

·
Registered
Joined
·
28 Posts
Discussion Starter #3
Thanks Jim, Didn't see a flasher on the fuse block. With the vintage air under dash installation it makes it a bit of a job to see a lot to the right side of the column. As a last resort, I'm going to follow the purple wire from the steering column disconnect until I locate it. Seems like things always have to be difficult!:yes:
 

·
Registered
Joined
·
28 Posts
Discussion Starter #4
Finally found it!

After another under dash search, the culprit was finally found. During it's long life, someone moved it from it's original location. I was eventually able to locate it between the heater controls and the glovebox inside the lip of the lower dash panel. Never was able to spot it with the mirror, so I just felt around until I got lucky. One more pesky problem eliminated!
 
1 - 4 of 4 Posts
Top