Chevy Nova Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
So I recently got my lt1nova project running, and has done good for about 2 weeks, then suddenly theres no power to the pcm.

The wiring harness I used to do the swap said to pull power from the original coil wire in the car, however I'm not sure what the PO had going on but wiring is kind of a nightmare here. So I tapped into the back of the seatbelt override box on the firewall.

Had one intermittent fix after hardwiring the circuit to the battery but then it failed again so I believe it's just a loose/corroded connect.

Can someone help me out with either tracing back that circuit or just finding a better location to get keyed (run and start) power?

Sent from my SAMSUNG-SM-G891A using Tapatalk
 

·
Registered
Joined
·
214 Posts
Keyed power

Please tell me the year of your Nova. Also never hard wire to the battery especially a computer needs to be fused. Hard wiring will cause a fire Let me know Neil
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
It's a 74 sorry about that, get rambly sometimes. And the hardwire was just to get it back home.

After messing with it for a few hours this afternoon and not being able to figure anything out I have ran a fused toggle switch. Honestly may just run with that until it's time for a full resto

Sent from my SAMSUNG-SM-G891A using Tapatalk
 

·
Registered
Joined
·
12 Posts
Discussion Starter #4
Ok would that circuit cause the battery to not charge or do I have another gremlin?

Sent from my SAMSUNG-SM-G891A using Tapatalk
 
1 - 4 of 4 Posts
Top