Chevy Nova Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
154 Posts
Discussion Starter #1
I bought these nice valve covers for my 66,but can't get them on they hit a bump in firewall that covers wiper trans.Tonite I was at the car show and saw 2 =67's(same,same 66)and there engines were at least 2 inches lower than mine allowing much room so that these covers would fit easily.What gives, do I have the wrong mounts or do I have the wrong supports that bolt to frame then ,to the mounts which bolt to block. May be I have 6 cyl ones,don't know if my car came with 6 or 283 as I have a 116 vin on on firewall tag but 115 on vin tag,they say this was done alot as they needed more V-8 cars so they exchanged engines on some latter 66's letting the option tag show that car left dealer with v-8 engine. Anyone know how to get my engine down does anyone have a set of these supports,that go from mount to frame?get back to me PLEASE.......
 

·
Premium Member
Joined
·
3,532 Posts
I bought these nice valve covers for my 66,but can't get them on they hit a bump in firewall that covers wiper trans.Tonite I was at the car show and saw 2 =67's(same,same 66)and there engines were at least 2 inches lower than mine allowing much room so that these covers would fit easily.What gives, do I have the wrong mounts or do I have the wrong supports that bolt to frame then ,to the mounts which bolt to block. May be I have 6 cyl ones,don't know if my car came with 6 or 283 as I have a 116 vin on on firewall tag but 115 on vin tag,they say this was done alot as they needed more V-8 cars so they exchanged engines on some latter 66's letting the option tag show that car left dealer with v-8 engine. Anyone know how to get my engine down does anyone have a set of these supports,that go from mount to frame?get back to me PLEASE.......
well, this is posted in the wrong section, and probably why you have'nt gotten any response, but....

the 115 in the VIN means the car was originally a 6 cylinder car, however you can't use 6 cyl. mounts on a V8. Not sure what the problem is. did someone make your brackets? That would be my guess that you just have the incorrect brackets. They're sold at any of the aftermarket places. Just get the correct ones with new rubber mounts, and that should fix any issues.
 

·
Registered
Joined
·
154 Posts
Discussion Starter #5
Its very close on my 63. I have to tilt the front up and then lift to clear the T-handdle bolt. and its becouse of the wiper motor mount area.
Was this car originally a 6 cyl car? I'm thinking the 6cyl mount fit but cause this problem.The original v-8 cars all seem to be lying much lower putting that bump on the fire wall higher and out of the way.....Gene
 

·
Registered
Joined
·
1,400 Posts
got any pics????? i have tall covers on my 66, like LUEPKE said i just have to tilt it up a lil.....

JOHN
 

·
Premium Member
Joined
·
2,217 Posts
Was this car originally a 6 cyl car? I'm thinking the 6cyl mount fit but cause this problem.The original v-8 cars all seem to be lying much lower putting that bump on the fire wall higher and out of the way.....Gene
I think all the 63 were 6 cyl. cars didnt the 64 start coming with the 8?
 
1 - 7 of 7 Posts
Top