Chevy Nova Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
298 Posts
Discussion Starter #1
A buddy of mine has a pontiac shorttail m20. He was wantin a yoke, i had one from a older th350 outta a 69 chevelle.. it wouldnt fit. anyone know the diff? they were both 27 splines but the yoke stopped right after the seal. See
ms just a hair too big in size.
 

·
Premium Member
Joined
·
3,151 Posts
On the weekend I pulled a powerglide out and put in a Muncie. The shaft fits perfectly, as far as I've seen the powerglide and Muncie are the same, with exceptions. Later 70's Muncies have a TH400 yoke and early air cooled powerglides have a coarse yoke that won't fit.

It sounds like you have a bad yoke or a damaged output shaft spline on the Muncie.
 

·
Registered
Joined
·
298 Posts
Discussion Starter #5
Yoke is clean. The diameter of the yoke is like 1/16 too big. I reput it in and it ALMOST clears, but catches the outside rim...
 

·
Registered
Joined
·
302 Posts
They have a pressed in brass bushing there in tail shaft housing I would pull rear seal and check that then you'll be able to see better what you issue is! Just a thought !
 

·
Registered
Joined
·
298 Posts
Discussion Starter #8
Found out the issue... He put a new bushing in, and the yoke had enough slight surface rust from setting four years. Sanded down the yoke and it was still a snug fit, but went in.
 

·
Banned
Joined
·
26,231 Posts
sounds like the bushing wasn't installed properly... i'd recommend removing the extension housing and having the bushing reamed/honed to the proper diameter. sounds like it's deformed and running too tight of a bushing on the yoke is just asking for future problems, premature wear etc...

i'd have it looked at by a qualified Automotive Machinist...
 
1 - 11 of 11 Posts
Top