Chevy Nova Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
171 Posts
Discussion Starter #1
Ok so all my lights blink except the front driver side. The bulbs do work when I turn the lights on but it doesnt flash. anybody know why?
 

·
Banned
Joined
·
26,231 Posts
if the rear bulb (same side) blinks then you've narrowed it to the wiring, bad/wrong bulb, bad ground connection...

if neither front or rear bulb blinks it could possibly be the flasher is bad...
 

·
Banned
Joined
·
26,231 Posts
What do you mean? The front passenger does blink. Its just the front driver that doesn't blink
the front & rear blink together. left side, right side... if ONE of the two doesn't flash then the issue will be at that specific location, ie, bulb socket not grounding, bad wire connection, bulb is bad etc...

if the rear driver's side blinks then the issue is at the driver's side front Only...

;)
 

·
Premium Member
Joined
·
4,600 Posts
make sure you have good connection between the bulb and electrical contacts in the socket
you can use a test light to make sure there is power at the socket
schwabie
 

·
Premium Member
Joined
·
7,437 Posts
Its just the front driver that doesn't blink
^^^ Here you are stating that just one bulb/light assembly is not functional.

Well the bulbs are good. So what can I do to make them blink. Check the wiring?
^^^ Here you are stating them (plural) meaning more than one.

Which is it ???

theFLYER has posted a detailed and very easy to understand description of what to check along with several possible causes regarding the issue you are describing. If it is indeed only one lamp that is not blinking., & all of the bulbs are good., then it would seem that you very well may have a non-ground issue at that particular lamp assembly, or possibly even a break in the wire at that location.....
 

·
Registered
Joined
·
171 Posts
Discussion Starter #12
Ok. All my bulbs are good. When I turned the lights on they all turn on. The problem is that.... Let's say I wanna turn left. The left lights should blink. but only the tail lights blink. Not the front left side.
 

·
Registered
Joined
·
331 Posts
Does the indicator light stay "on"?
If so, it's trying to tell you where the problem is.
Check the ground and ensure the bulbs are good.
 

·
Premium Member
Joined
·
7,437 Posts
Ok. All my bulbs are good. When I turned the lights on they all turn on. The problem is that.... Let's say I wanna turn left. The left lights should blink. but only the tail lights blink. Not the front left side.
This is a much improved description of the problem. :yes:

Also please post what year car you have....
 

·
Banned
Joined
·
26,231 Posts
if i recall correctly if this is a marker lens and not a turn signal... it doesn't flash, it stays on. the turn signal will flash though.

is that what you're referring to?

what year car is this?
 

·
Premium Member
Joined
·
2,561 Posts
If you have a 1st gen car the front turn signals are grounded thru the 2 mounting screws on the lens cover. Check by running a jumper ground wire to the screw.
 
1 - 16 of 16 Posts
Top