Chevy Nova Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
HEELLP
I have a back halved 67 nova, which has been around a while and after buying it I decided "stupidly" to stick my BBC into it.
Any way the problem I am having is after installing the "Smith Racecraft" front clip and motorplating the BBC in, I had the old leafs changed and went for a coilover set up with New double adjustable ladder bars.
Although all this work was done by a chassis builder he was obviously working with my existing set up.
The car bites "HARD" on 32x14.5 slicks but lifts the drivers front wheel
"WAY UP" in the air and stuffs the Pass side back bumper on the FLOOR.
I mean BADLY.
I am getting the car back to another "Highly Respected" chassis builder in a week or two but HE tells me this CANNOT happen with a Ladder Bar car!
Has ANYONE suffered this OR knows WHY this should affect MY 67.
Many Thanks
 

·
Premium Member
Joined
·
11,208 Posts
Chassis or body flex will do it real easy. Is the car tied together with enough cage to make it rigid? Another thing is the rearend housing. If it flexs or the brackets or LBs flex it will happen. RM
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
Well what'ya know I was just reading a thread about ladder bars on a 62 and you seemed very helpful on that one too.
As I say I am having the car looked over properly this week just trying to get more input from others.
My Chassis Guy has warned me it seems like Axle OR possibly chassis flex i just can't believe it would affect it that bad.
I have an 8.50cert cage in the car and s/frame connectors with a couple of "crossbeams" I have a sneaky feeling my axles tubes are not fully ( or at all ) welded!
He is suggesting already ( without seeing it in the flesh )that I may want to brace the axle and/or tie the top of the front clip into the Roll cage as it only bolts to the firewall/bulkhead.
I have a picture and a lovely video but only on my e-mail and don't know how to attach to a thread .
If anyone knows how you'll have a great laugh looking and watching them !!!
 

·
Registered
Joined
·
1,079 Posts
i have seen both Dana 60 & 12 bolts spin the tubes & body roll on the launch.

also saw a super gas ladder bar car with a broken weld om the axle bracket do the same thing.

any play or slop in the bars or hardware will contribute to a roll problem
 

·
Vendor
Joined
·
4,056 Posts
If your axle tubes are not welded 360 degrees you will not beable to stop this problem. I had tubes in a 12 bolt that were only partially welded from the previous owner, when the weld let loose the back right side darn near touched the ground and the left front was 3 ft. in the air. Prior to this happening the car would launch nice and square.

Fast forward........... 700 hp and a completely welded aftermarket 12 bolt. I had many years of flawless launches with 500hp. I added the larger engine and started launching crooked and not square. It turned out that the welds on the passenger side were broke. I fixed the problem only to have it happen again a couple of weeks later. This time I found the driver side was starting to crack as well. I found that the cracks were beginning on the back side of the tubes, thus telling me that they were not twisting in the houseing but I was bending the whole rear end like a bananna! Instead of making a brace to work with the 12 bolt I elected to go for a Fabricated housing using a back brace.

Point is this: with the big block and your description you will definately need some sort of back brace on the rear end or you will keep fighting the problem. Also as suggested earlier you should have your cage tied into the front subframe.

Good luck!
 

·
Registered
Joined
·
11 Posts
Discussion Starter #6
WOW
Thanks for the response
Well I guess I'll have to take a better look at those welds !!
Obviously I did look over the whole lot for any kinda cracks,breaks or movement, Couldn't even see where any "grime" had moved.
Thanks Guys
P.S Do I need to open an "account" with an on-line co.
To be able to share any of my pics on Forums ??
Craig
 

·
Registered
Joined
·
11 Posts
Discussion Starter #8
Photo update 67 ladder bar body roll


Thanks for the info think i've got it now have a look at this !:confused:
 

·
Premium Member
Joined
·
6,444 Posts
I had the same problem on my wagon. Maybe not quite that drastic as your's but close. Now on mine I have coil over's and I adjusted the right rear coil over. So that it was a little stiffer on the initial hit on the right rear shock. Now my rear end is braced. Now I am not saying this will work for you. Or that you may have not already try this. But this what worked for me and thought I was suggest this to you.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #12
Thanks Guys for all the help !!
Figured it out!
AXLE TUBE BUSTED and rotating around housing!!
Should be sorted in next week
Yeehaaah !!!
 

·
Registered
Joined
·
1,079 Posts
I just had a customer in this weekend.... 12 bolt spun one tube & started rolling on the launch, then the other one broke, pinion hit the floor.
His tubes were not welded at all..

FAB9 time !
 
1 - 13 of 13 Posts
Top