Chevy Nova Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
89 Posts
Discussion Starter #1 (Edited)
first off i made a thread in drivetrain to no avail....

2 problems:

first it dies everytime i give it gas. so im thinkn its fuel pump. i know my timing is off and has been since ive gotten the car, but its never acted like this. could it have jumped timing again? or is there a fuel pump relay of some sort that failed?....this is the biggst problem im having...

secondly wen i bought the car it had an aftermarket h/u. i went to go check the wires and im lost. theres one main wire im concerned about. its red, and combined witha red and black. i assume one is ground and one is power but theyre spliced into and go directly to the radio harness. are those wires supposed to go to the radio or did they rig it to make it work?. the last thing is there are 3 clips under there that go to nothing. one is small and orangish redish and the other is a big black clip, the last one looks like a mini light bulb socket but where wud that go... i cant find a home for em.....

sorry for the long read but im trying to get my baby back on teh road and im frustrated. thanks

edit, and another thing about the wires is that i realized whoever wired the car before me had left the yellow wires bare and wrapped the rest in electrical. then it touched a tiny piece of wire showing on the ground connection and sparked. did it do more then jus blowing the fuse or am i ok.?
 

·
Registered
Joined
·
438 Posts
first it dies everytime i give it gas. so im thinkn its fuel pump. i know my timing is off and has been since ive gotten the car, but its never acted like this. could it have jumped timing again? or is there a fuel pump relay of some sort that failed?....this is the biggst problem im having...
When you hit the gas and your car dies, does it happen when accelerating or while standing still idling? How does it die, immediately or does it slowly start to sputter then die? Does it try to backfire at all?

If the fuel pump was completely bad I wouldn't expect it to run at all. If it was a bad pump not flowing enough fuel I would expect it to sputter and slowly die coming back to life momentarily as you pump the gas because there is still some fuel in the squirters of the carb. If its timing related it may try to backfire.

You talk about a fuel pump relay, is it an electric pump? I don't know of any mechanical pumps which use a relay...or any wiring. Do you happen to have fuel pressure gauge?

I'm not ignoring your other electrical problems, I'm just unfamiliar with stock wiring colors so I'll have to let someone more knowledgeable answer.
 

·
Registered
Joined
·
3,959 Posts
Your '77 would have come with a mechanical fuel pump. So unless some converted to an electric one, there is no fuel pump relay.

If you go to this sticky thread Call for all Generation Wiring Schematics and select 1978, it has both the 1977 and 1978 wiring schematics. This should help you trace out the wiring.
 

·
Premium Member
Joined
·
4,365 Posts
Possibly a bad fuel pump or a bad accelorator pump in the carb.

What is an H/U?
 

·
Registered
Joined
·
89 Posts
Discussion Starter #5
it dies both when idling and gas or accelorating. it slowly dies and sputters out. im not sure if it backfires i dont think it does.

thanks for the link to the wires that should help me.

and h/u is headunit aka radio
 
1 - 8 of 8 Posts
Top