Chevy Nova Forum banner

1 - 20 of 20 Posts

·
Premium Member
Joined
·
13,309 Posts
Discussion Starter #1
I dont know as yet what broke... I started the nova to take it to the funereal for my bud mike....... washed the car, and let it idle while it was washed.. because it had not been driven in a month.....

after the wash, I opened the door and reached in to bip the throttle twice..... which was all good... then................

pop,pop,pop,pop,pop,pop,pop, ????? did I blow a flange gasket? bliped the gas again???? pop,pop,pop,pop..... and now steady... every 8th pulse..... crap.... shut it off... push it in to the.... garage..... crap....

its popping in the intake.... bad... I can think of only a couple of things.... broke spring, retainer, keeper, or a stelite seat let go....

either way I got a intake valve hanging open....

stay tuned!:D

Veno
 

·
Premium Member
Joined
·
13,309 Posts
Discussion Starter #3
Nope.. its definitely a open intake valve during the power stroke... I have heard it before.....
 

·
Registered
Joined
·
4,760 Posts
just making a pop noise maybe just the vavle spring ( hopefully ) unless you put a hole in the top of the piston :eek:
 

·
Registered
Joined
·
4,760 Posts
maybe you wiped out a lobe on the cam and its the cam youd think that with the valve hanging open that the motor would blow even when you started it and let it idle :eek:
 

·
Premium Member
Joined
·
13,309 Posts
Discussion Starter #6
flat lobe= valve closed.....

If you have ever heard a open intake valve on the power stroke.. it makes a distinctive combustion pop in the intake and through the carb....
 

·
Premium Member
Joined
·
4,365 Posts
Hopefully just some crud on the intake valve face. Maybe an intake valve is burnt. Wouldn't you hear something clanking under the valve cover if you broke something?
 

·
Premium Member
Joined
·
13,309 Posts
Discussion Starter #8
not with my cam:D to radical.... I am almost sure it a broke spring:(.... I will pull the valve covers tomorrow... if not a spring.. then I will pull the top end.... no big deal...... the worst would be a hardened seat dislodged....

if that is the case.. I will give Shawn a call and see if he would be willing to take my heads and do his magic....
 

·
Registered
Joined
·
379 Posts
I had an exhaust pushrod come apart once and it made that same popping sound your describing. I guess it was the exhaust coming out when the intake opened.
 

·
Registered
Joined
·
2,600 Posts
Found this in a F'rd once, you wouldn't think it but the sound it was making was horribly loud and sounded like it was coming out of the intake. Tear it down and fix it. :yes:

 

·
Premium Member
Joined
·
8,405 Posts
Because you were washing the car, there's the possibility it's water causing the HV to cross fire in the distributor cap.
I'd check that out first since it's easy, but if the sound is rhythmic and regular then you may be right.
 

·
Premium Member
Joined
·
13,309 Posts
Discussion Starter #13
no broken springs.... this is what I found......
a three piece set:D

Note the wallered out roller shaft hole

Note the pushrod cup

Inside look at the push rod cup as it broke through...

better view of the push rod cup protrusion

push rod cup displaced

Wear pattern of the retainer and scuffing where the roller used to be


So now I am in the market for a new set of roller rockers.. I will scrap these....

what do ya guys think of the Comp promagnum Chro. moly 8620 rockers? I would do shaft rockers but(T&D sportsman).. the shop has to come first:D....
 

·
Registered
Joined
·
748 Posts
Well atleast you don't have to pull the heads off. You gonna replace all the rockers and pushrods? Or just thr broken one? I would go ahead and replace all of them.
 

·
Registered
Joined
·
4,760 Posts
hey veno im running the comp pro magnums and i love them never had a problem with them and ive had them for 5 or 6 years with no problems what so ever. i would recomend replacing the pushrods as well you may have a bent one at least it was any easy fix. i used to have a pair of crane aluminum body roller rockers and they made way to much noise so i replaced them with the pro magnums from comp. you said you want to run them shaft mounted type for these are the best in the buisness i perfer jesel though but there way out of my price range ive installed them on a friends car and there really good its all prefrence and budget imo :yes:
 

·
Premium Member
Joined
·
13,309 Posts
Discussion Starter #19
Hey Veno were those the Crane Gold series rockers or another brand?
they are Miller Mid lift.... made in the USA.. in FLA..
very interesting web site

http://www.mid-lift.com/MASTER-INDEX.htm

Veno;
What held the valve open?

Don
Don.. I am going to hazard a guess by looking at the rocker body, that the trunnion body, was binding with the retainer and holding it open just a whisker... I have not inspected the other rockers or push rods yet... nor have I look at the valve to see if the stem is bent....
 
1 - 20 of 20 Posts
Top