Chevy Nova Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
179 Posts
Discussion Starter #1
I rebuilt my Holley 750 with vac secondaries. Got it put on and had my engine ready to fire for the first time. I filled the bowls with fuel and engaged the throttle to squirt some fuel in and there was nothing squirting. I messed with the pump adjustment but didnt get anywhere. The lever on the pump acts like it dosent want to move much, when i pull the throttle it just compresses the spring on the engagement arm and dosent hardly actuate the pump.

I need to get this sorted out before I can break in my new engine. Dont want to wipe the cam, ya know.
 

·
Registered
Joined
·
442 Posts
Sounds like the pimp has been assembled wrong, Id pull the front bowl off and disassemble the pump and check everything.
 

·
Registered
Joined
·
179 Posts
Discussion Starter #4
The diaphram assembly is rubber and one side of it has gasket material made onto it. Does the gasket material go towards the bowl or the pump housing? Ive got it toward the pump housing now. I thought thats how the old one came off but maybe I got it mixed up.
 

·
Registered
Joined
·
290 Posts
Good video, if all fails you might want toremove acc pump completly and inside of the pump housing there is either an umbrella or a check ball embedded in a small hole, make sure that check ball is present or if umbrella is snug. If that check ball isnt there pump will not work
 

·
Registered
Joined
·
179 Posts
Discussion Starter #7
Good video, if all fails you might want toremove acc pump completly and inside of the pump housing there is either an umbrella or a check ball embedded in a small hole, make sure that check ball is present or if umbrella is snug. If that check ball isnt there pump will not work
I think I have the umbrella. it was a round red rubber piece that had a nipple one one side that went through a hole in the float bowl. I replaced it with the new one in the kit. Seems to be fine, I installed it just as the old one was. I did not see a check ball during dissassembly. But if I have the umbrella do I still have a check ball or not? Its a 4160.
 

·
Registered
Joined
·
565 Posts
I think I have the umbrella. it was a round red rubber piece that had a nipple one one side that went through a hole in the float bowl. I replaced it with the new one in the kit. Seems to be fine, I installed it just as the old one was. I did not see a check ball during dissassembly. But if I have the umbrella do I still have a check ball or not? Its a 4160.
Both do the same thing so will have one or the other, if you have the umbrella you won't have the check ball because the check ball goes in the same place..
 

·
Registered
Joined
·
185 Posts
Maybe take a look at the Acc. pump passage.


The port marked "D" is the pump port. Spray some carb cleaner in it and blow it out good making sure it sprays through the oppisite side. Also make sure the fuel bowl gasket isnt interfering. I believe they have holes on both sides for the passage but you never know. Could have been a miss cut when they made the gasket.



In the carb main body the port marked "B" is the one going up to the squirter. Check this too for any blockage.
 

·
Registered
Joined
·
179 Posts
Discussion Starter #11
Well I took everything apart. With the bowl removed the pump squirted as it should. I checked all the passages and gasket orientation. All was good. But something was blocking the fuel from the squirter so I took out the squirter and removed the needle and blew it out with carb cleaner, reassembled and now it works fine. Thanks for all your input.
 
1 - 11 of 11 Posts
Top