Chevy Nova Forum banner

1 - 3 of 3 Posts

·
Premium Member
Joined
·
2,217 Posts
Discussion Starter #1
Hey guys I need some help with my 04 Dodge Ram. About 2 months ago one of my brake lights stopped working. I kept forgeting to replace it and today I was told that both brake lights were out so I checked and they were both out (the top center cab brake light is still working). Well I figured I better take care of this so I just bought 2 bulbs. I went to change them and both of the old bulbs were good. The parking and turn lights are working on both sides so I tested the old brake lights in the turn socket and both are good. All three bulbs are the same style. So I checked for a popped fuse and all the fuses are good to. What could be the problem. The thing that gets me is the center cab brake light works just fine when I apply the brakes and one of the tail brake lights stopped working before the other by about 2 months. Any thoughts? I know its not a Nova but please help.

Thanks
 

·
Premium Member
Joined
·
2,217 Posts
Discussion Starter #2
One other thing that just came to mind. I notice the left brake and turn sig. didnt work on my trailer last summer. There wasnt any power getting the the rear trailer plug and again the fuses and bulbs were fine. I think its all the same problem. Any thoughts?
 

·
Registered
Joined
·
566 Posts
Since it's a newer vehicle, probably not an issue due to rust.

Possibly a problem in the turn signal assembly.

Not familiar with the newer vehicles, but also possibility that you have a bad connection at the firewall plug.
 
1 - 3 of 3 Posts
Top