Chevy Nova Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
110 Posts
Discussion Starter #1 (Edited)
so i went to team c in bellflower the other day to get my header bolts and take care of tht annoying leak.. so sounds great now ... took a drive to auto zone needed some power steering fluid.... i go to start my car i give it a lil gas to rev it up and BAM!!! something snaps my gas peddle is to the floor i can push it and it wont come up iam guessing my throttle cable??? ... i just spent all i had to get my motor running good looks like iam not driving the nova for a while :(.....i opened the hood took off the air filter and i played with the cable it lags on retracting ..any thoughts???
 

·
Premium Member
Joined
·
5,858 Posts
Sounds like the cable broke to me. You should be able to find one somewhere - try the classifieds on this site, or you can go buy an aftermarket cable setup like a Lokar and make that work....
Did you check to make sure the throttle return spring on the carb isn't broken?
 

·
Registered
Joined
·
110 Posts
Discussion Starter #3
Sounds like the cable broke to me. You should be able to find one somewhere - try the classifieds on this site, or you can go buy an aftermarket cable setup like a Lokar and make that work....
Did you check to make sure the throttle return spring on the carb isn't broken?
yea thts wat i think it is bro ..iam going to check out tht spring too ..iam a noob... so iam learning as i go thanks for all the help :yes:
 

·
Premium Member
Joined
·
31,194 Posts
Feel free to ask what ever you need, none of us were born with all our knowledge, we have been educated too. There will always be someone who knows more, I just hope he/she is here to help!:yes:
 

·
Premium Member
Joined
·
4,072 Posts
If it's the cable I have a 74 parts car with a good cable.
 

·
Registered
Joined
·
110 Posts
Discussion Starter #7
iam not really sure

If it's the cable I have a 74 parts car with a good cable.
iam really not all that sure...iam a noob iam just learning as i go iam thinking of m,aybe taking a course on mechanics so i knw the basics never been into it till now ...but its pretty much wat i describe a cable would be great :yes:
 

·
Registered
Joined
·
1,694 Posts
definitely check for the spring that connects to the carburator linkage (that would be the throttle return spring) mine broke, except i was in the middle of a turn in the rain and the car went wide open throttle and i took out a metal posted mailbox with my passenger door :mad:. But thats been fixed and all is well, i learned my lesson and replaced it with a dual spring setup.
 

·
Premium Member
Joined
·
667 Posts
so i went to team c in bellflower the other day to get my header bolts and take care of tht annoying leak.. so sounds great now ... took a drive to auto zone needed some power steering fluid.... i go to start my car i give it a lil gas to rev it up and BAM!!! something snaps my gas peddle is to the floor i can push it and it wont come up iam guessing my throttle cable??? ... i just spent all i had to get my motor running good looks like iam not driving the nova for a while :(.....i opened the hood took off the air filter and i played with the cable it lags on retracting ..any thoughts???
Hey Drew, dude if you need me to come look at it i can, just let me know when is a good time. PM me if you need help.
 

·
Registered
Joined
·
110 Posts
Discussion Starter #11
definitely check for the spring that connects to the carburator linkage (that would be the throttle return spring) mine broke, except i was in the middle of a turn in the rain and the car went wide open throttle and i took out a metal posted mailbox with my passenger door :mad:. But thats been fixed and all is well, i learned my lesson and replaced it with a dual spring setup.
yea bro it was the spring it snapped ...tht sucks sryu to hear glad everythings fixed now... yea i replaced it and runs fine now gas peddle even feels stiffer : ) thanks for all the help
 
1 - 12 of 12 Posts
Top