Chevy Nova Forum banner
1 - 6 of 6 Posts

·
Premium Member
Joined
·
254 Posts
Discussion Starter · #1 ·
I have posted some of this before --- but I a have the biggest problem with new OER gauges and speedometer purchased from Classic Industries. My oil gauge starts off working well, that is until I rev the engine. When I do that the oil guage goes past pegged and then only goes back to 60 lbs when shut off and stays there. This is my fourth gauge and it is getting old taking the cluster out and replacing the oil gauge, not to mention I have bought 3 sets myself, Classic Industries replaced one free of charge. The original gauge worked fine and I only replaced it because it was looking old. I put a new speddometer and now when driving the needle bounces between 10 mph and 70 mph and is making noise in the guage cluster. The old one worked well and I replaced as it was looking old. I email OER and even sent them a video and they never answered. Any thoughts or experience?
 

·
Premium Member
Joined
·
4,883 Posts
not sure about the oil gauge, make sure the speedo cable is engaged all the way is the only thing I can think of for the speedometer
 

·
Premium Member
Joined
·
254 Posts
Discussion Starter · #4 ·
oil line was not changed from original oil gauge which worked fine. Speedoeter did about 6 total rotations and hear a noise in it now doesnt work. My bother, myself and my mechanic all have changed the gauges in this car. My mechanic has an amazing back ground with these older cars and works ona lot of cars for hot August nights. He is also shaking his head. Could it be I got a bad batch from OER?
 

·
Registered
Joined
·
987 Posts
That's a possibility. Unfortunately in this day and age it's only going to get worse. Coworker bought 3 replacement fuel pressure regulator a before he gave up and bought an oem
 

·
Premium Member
Joined
·
254 Posts
Discussion Starter · #6 ·
Just called Classic Inductries they are refunding me both for the Speedometer and Gauge cluster ---they are amazing there! -- I will paint the needles on my originals and clean them up and install them. They told me especially for the gauge cluster they have had a problems with OER ones with other customers and are going to ask OER to rectify it!
 
1 - 6 of 6 Posts
Top