Chevy Nova Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter #1
It's been a while since I last logged on. Been pretty busy and just got around to replacing my ignition switch as of yesterday lol.

I just installed a brand new battery and when I tried cranking it, the Generator, temp, and oil light turns on. It also won't start up and has this beep sound that goes off.

It's also an inline 6 if that helps.

Any help is appreciated!
 

·
Registered
Joined
·
61 Posts
Discussion Starter #3
More info needed. Does the starter turn over? Click? Or nothin'?

Those lights coming on are all normal and switch off after the engine starts (if all is well).

The buzzer - shut the door when you are turning on the ignition. That is the "hey dummy, you left the keys in the car" warning. :)
The starter does not turn over. Could possibly be a bad starter then?
...and yes, I have tried cranking it with the door closed.

Forgot to also mention that the car has been sitting for 10+ years lol:D
 

·
Registered
Joined
·
61 Posts
Discussion Starter #6
Let me try again with the description.

With the key in Accessory mode, The Gen and oil lights are on, but as soon as I turn the key to start it, the Temp light turns on and a loud beep sounds goes off. a sound something like a buzzer when you give the wrong answer to something lol
 

·
Registered
Joined
·
202 Posts
Try the nutral safty switch my wires fell off an ffff it was confusing if you change ignition switch if it's like mine maybe you got the connector backwards or a few wires just missed a spot my neutral safety switch came with an adapter that I had to look up to get it going
 

·
Registered
Joined
·
202 Posts
My ignition switch sorry typo that came with an adapter that I had to custom fit into the car was it hard just a little confusing then everything works fine for a while went out 1 day the car wouldn't start I'd checked everything it checked out okay for some reason I checked underneath the steering column on the neutral safety switch turns out it was un plugged plugged it back in and it worked
 

·
Premium Member
Joined
·
3,563 Posts
My ignition switch sorry typo that came with an adapter that I had to custom fit into the car was it hard just a little confusing then everything works fine for a while went out 1 day the car wouldn't start I'd checked everything it checked out okay for some reason I checked underneath the steering column on the neutral safety switch turns out it was un plugged plugged it back in and it worked
^^ good thing to check. :yes:
 

·
Registered
Joined
·
61 Posts
Discussion Starter #11
Nova brothers, this being a later model car does it have the seat belt warning buzzer? This might be the buzzing sound... unless the starter is grinding on the flywheel making the noise. Opinions?
you know what?! I think you may be right! I think I remember my uncle mentioning that a while back lol..let me give it a try!
 

·
Registered
Joined
·
61 Posts
Discussion Starter #12
So come to find out that it does in fact crank, thanks to 69LT1NOVA! lol :doh:
But it sitting for so long, the engine will not start. I may need to flush the oil I guess.
 

·
Premium Member
Joined
·
3,563 Posts
Glad to help, but slow it down a notch. I've resurrected several barn finds in my day, and this is my routine:

1. Pull the spark plugs and put a teaspoon of Marvel Mystery Oil in each cylinder
2. Turn the engine over by hand several times
3. Re-install spark plugs
4. Drain the gas tank and put in fresh gas
5. Shot of starting fluid down the carb
6. Let 'er rip

Replace the oil if it looks dirty.
 

·
Registered
Joined
·
61 Posts
Discussion Starter #14
Glad to help, but slow it down a notch. I've resurrected several barn finds in my day, and this is my routine:

1. Pull the spark plugs and put a teaspoon of Marvel Mystery Oil in each cylinder
2. Turn the engine over by hand several times
3. Re-install spark plugs
4. Drain the gas tank and put in fresh gas
5. Shot of starting fluid down the carb
6. Let 'er rip

Replace the oil if it looks dirty.
I'll give that a try! Thanks again for the help! I'll let you guys know how it goes!
 

·
Premium Member
Joined
·
3,563 Posts
Draining a gas tank all the way sucks. To get everything out you need to drop it from the car...

Most of the time you can get away with siphoning the tank with a fluid transfer pump (auto parts store under $10), and putting fresh gas in. Keep in mind that all the gas in the line going to the carb is bad, so you'll need to crank it over several times to purge the system.
 

·
Registered
Joined
·
61 Posts
Discussion Starter #17
Draining a gas tank all the way sucks. To get everything out you need to drop it from the car...

Most of the time you can get away with siphoning the tank with a fluid transfer pump (auto parts store under $10), and putting fresh gas in. Keep in mind that all the gas in the line going to the carb is bad, so you'll need to crank it over several times to purge the system.
Ok cool, thanks a lot!
 

·
Registered
Joined
·
61 Posts
Discussion Starter #20
:( well, that sucks I guess lol. I'll figure it out somehow :) thanks again for all the help man! I'm new to all of this so it's much appreciated!
 
1 - 20 of 20 Posts
Top