Chevy Nova Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
225 Posts
Discussion Starter #1
I've had the Church boys front end R&P uppers, coil overs, lowers installed for over a year now last year it was fine took it out the other day and at 65 MPH the steering wheel had so much vibration that I had to slow down to 55 in order to drive it without and shaking. Is there anything I need to check been over everything a few times and can't see anything! Do I need another wheel alignment like I said it was fine last summer after it was aligned and now this!
Help! I need to drive my car!
Thanks Rich
 

·
Registered
Joined
·
2,430 Posts
If everything was fine a year ago and now it’s not, wheels and tires are the first thing I would look at.. You could have lost a wheel weight especially if they are the adhesive stick on type.. I’ve found them laying on the ground next to my wheel before.. Out of balance wheels usually become pretty obvious at or above 60 mph..
 

·
Registered
Joined
·
236 Posts
I had a front end vibration that got worse over time.. turned out I had a wheel spindle nut that wasnt torqued down enough and let the wheel bearing get a little loose... check the basics!! its often the simple things.
 

·
Registered
Joined
·
236 Posts
I had a similar problem.. turned out one of my spindle nuts/wheel bearings was JUST SLIGHTLY loose.. like not enough that I could move the wheel.. but when I pulled it, I could loosen by hand... since putting it back together and properly torquing, no more shakes!

Now I drive too fast because it feels like I am driving on rails it handles so good!
 

·
Registered
Joined
·
225 Posts
Discussion Starter #8
Replaced the wheel bearing and still have the same problem maybe a little less so now I'll have the wheels balanced to see if that makes a difference the car just sit most of the time hardly used due to Grand daughter playing softball and I have to be there! tires are new last year and balanced then but will see how it goes!
 
1 - 9 of 9 Posts
Top