Chevy Nova Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
I just rewired my 67 nova with an American Autowire Kit. Everthing works great except my front turn signal lights when my parking/headlight switch is turned on. Both the right and left turn signals flash very softly. You really have to look to see if they are flashing. My rear turn signals work fine. Again if the parking/headlight switch is turned off both right and left turn signals function properly. Thanks for the help. :confused:
 

·
Registered
1974 Nova, 1977 Nova
Joined
·
2,056 Posts
Hi Novachef,

The symptoms you described indicate bad ground connections at the front turn signal lights. With the parking/headlight switch off, the signal light filament of the dual filament bulbs can ground through the parking light filament/circuit and appear to be working okay.

If I'm not mistaken, 1972 & earlier Novas ground the front parking/turn signal lights via the metal shell of the bulb sockets making contact with the metal light housings. Make sure the new sockets are fitting tight into the housings. You may need to gently bend the little tabs on the sockets out for a tighter fit. Also check to see that the housings are free of rust and corossion (particularly where the sockets snap in).

If the sockets and light housings all check out okay, you could have a problem with the housings not making a good ground contact with the bumper. Or maybe even the bumper not making a good ground contact with the rest of the car.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #4
Thankyou. I will try that tomorrow.
 
1 - 4 of 4 Posts
Top