Chevy Nova Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
247 Posts
Discussion Starter #1
Hey...so I broke rule #1 of restoration. I took off my bolts without documenting where they go. I thought my new suspension kit would come with new hardware, but I was wrong. Does anyone have access to a diagram or some kind of description of what bolts go where and the order the nut and washer goes? It is for a 74
 

·
Registered
Joined
·
3,816 Posts
its hard to explain in words, if you can post up pics of the bolts and nuts and the parts you are putting together on the suspension, will be easier to tell you what they are for. Also an assembly manual will help a lot
 

·
Registered
Joined
·
247 Posts
Discussion Starter #4 (Edited)
So I got most of it figured out. Luckily on my left control arms I put the bolts back in the holes so it was easy to figure it out. But I do have a question. Are the lock nuts reusable?


this is what the replacement nuts looks like on Summit so I am pretty sure these are the right ones.
 

·
Registered
Joined
·
3,816 Posts
So I got most of it figured out. Luckily on my left control arms I put the bolts back in the holes so it was easy to figure it out. But I do have a question. Are the lock nuts reusable?


this is as far as I can get them on. For both the upper and lower.

this is what the replacement nuts looks like on Summit so I am pretty sure these are the right ones.
I don't see any pics, but the locknuts are reuseable
 

·
Registered
Mike - 74 Nova Baltimore, MD
Joined
·
1,536 Posts
I also do not see any photos... but yesterday I remember seeing some photos in your other post that have now also vanished.

Question.... did you move the photos within your photo hosting site after you had posted them?
Example: Attach photos to your post from your photo hosting site... then move photos to a different folder/area within your photo hosting site (or rename the folder with the posted photos).

Doing this could cause your posted photos to disappear for other forum viewers... even though you can still see the photos in your post.
 

·
Registered
Mike - 74 Nova Baltimore, MD
Joined
·
1,536 Posts
I also use Goggle Photos to post images. One other thing to check.

Open Google Photos and then click on the Albums Icon in the Left Hand Panel.


At the bottom of the Photo Album(s), it should say "Shared".


If the album(s) containing the posted photos is not "Shared", you will be the only person that can view the photos in your post.
 

·
Registered
Mike - 74 Nova Baltimore, MD
Joined
·
1,536 Posts
maybe that is my issue. I am not putting them in albums.
You don't need to have separate albums for all of your photos. They can all be in one album/folder... but that album/folder must be "Shared".

Note: If you start moving photos to different albums after you have already posted the image, the image will be lost in the post (even if all of the albums are shared).
 
1 - 12 of 12 Posts
Top