Chevy Nova Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
340 Posts
Discussion Starter #1
This may need to go in a sub forum. Not sure. I installed the 1200 HP power adder FiTech on my 383 Nova a few months back. It’s the best thing I could’ve done for that car both for performance and drivability. I’ve been having an issue of when I do a couple of quick blips of the throttle while parked and in neutral, tgecmotorctends to wanna stumble and almost die. Sometimes the rpm’s will pick back up and a quick third blip will kill it completely. If revs just fine when I want to rev it. I’ve attempted to mess with some parameters and seems to be better at times. Im afraid I’ve tuned myself in a corner. Short of just hitting the relearn, does anyone know which particular parameter I need to focus on? Any help would be appreciated. Thanks, Matt
 

·
Registered
Joined
·
287 Posts
FWIW, I have the Street version (max 400hp) FiTech system on my Gen1 SBC and have yet to get it dialed in. 3 different shops, numerous calls to FiTech by multiple mechanics... and I still get: hesitation like a carburetor; occasional backfire; and uneven idle and fuel delivery. Even after a full range of timing settings. So basically I’m having similar issues you’re hav but just on a smaller hp scale!��

Wondering now: should I have stuck with the Holley 650cfm double pumper?
 

·
Registered
Joined
·
1,495 Posts
Total Fitech novice here, but...

To me, that sounds like throttle position sensor issue and/or improper O2 sensor placement.
 

·
Registered
Joined
·
340 Posts
Discussion Starter #7
Sorry guys! Been away for a bit. I hit the relearn button so it could start over learning and the throttle blip is still the same. ISC steps start out at like 90 but quickly came down to settle around 18. I’m gonna reload the program I had in it before and see what it is.
 

·
Registered
Joined
·
340 Posts
Discussion Starter #8
No exhaust leaks. Runs like a scalded dog! I’ll never put a carb back on it! Just the idle blip issue.
 

·
Registered
Joined
·
340 Posts
Discussion Starter #10
Idle steps in the tune I’ve had in it for a while and been messing with is around 28 give or take a couple.
 

·
Registered
Joined
·
295 Posts
The IAC steps should be between 3 and 10 at idle with a warmed up engine. I would warm up the engine, shut the car off wait for all the numbers on the handheld to go blank then turn in the screw for the throttle blades on front right of the fitech half a turn clockwise and see where that brings you in at. I had some issues with hanging idle and long crank until i adjusted mine now all is great.

What fuel pump and filter fo you run?


Idle steps in the tune I’ve had in it for a while and been messing with is around 28 give or take a couple.
 

·
Registered
Joined
·
340 Posts
Discussion Starter #12
I’ll try that. I’m running the Tanks Inc GPA 6 and the FiTech in-line filter. Brand new tanks Inc FI tank.
 

·
Registered
Joined
·
340 Posts
Discussion Starter #13
I had the IAC steps Around 5-7 when I initially set system up a few months back. Can messing around with the tune cause it to get out of whack?
 
1 - 15 of 15 Posts
Top