Chevy Nova Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter · #1 ·
My friend has a problem that he cannot figure out. He has a SBC, glide w/ transbrake, delay box, MSD 6AL, 2 step. Motor, trans, and converter have been sent out to be checked and ok, but no matter what chip, or any chip at all is in it, the motor only flashes to 3200. What's the problem?
 

·
Premium Member
Joined
·
11,208 Posts
It sounds like he has the wrong converter for his motor combo. If he had a converter built for a 500 HP motor but he only had 300 HP it will never work even though the converter is in good condition. Now that is based on the motor running properly and not skipping and running poorly. Your post suggests it does run properly. RM
 

·
Registered
Joined
·
63 Posts
Discussion Starter · #6 ·
I will try to regenerate this thread. His motor will rev up high in neutral, but any time he engages the transbrake, it will only rev to 3200 rpms. He has changed:

motor
transmission
converter
msd

The only thing not changed is:

distributor
shifter with electric shiftnoid
wiring

He also disconnected the delay box.

This is all the information given to me. He has had this problem for the past year since building the car. He runs low 12's, high 11's @ 138 mph (1/4 mile) launching very lazy, but alot of top end.

Thanks in advance
 

·
Premium Member
Joined
·
9,228 Posts
Sounds like the Launch RPM setting or chip is what's limiting it. When you release the TBrake, it then goes until whatever setting or chip is in it for RevLimit. Sounds like the TBrake is putting it on the first step whatever that's set to.
 

·
Registered
Joined
·
63 Posts
Discussion Starter · #8 ·
I forgot to add that he told me, whatever chip is in it, and even with no chip at all, he only gets 3200 rpm while activating the transbrake.
 

·
Registered
Joined
·
438 Posts
Any chip makes it stall at 3200? Lets say even a 2800 or 3000 chip? (how low do they go?)

Obviously if the converter only stalls at 3200 then no chip above that will make it stall higher. If the 3000 rpm chip makes it stall to 3000, I'd say it has to be in the converter.

138 mph does seem awfully high for a high 11 second car. I'm thinking when I ran 11.90's my mph was only about 101. I'd expect a mid 9 second pass at 138 mph, does that seem about right to everyone else?
 

·
Premium Member
Joined
·
11,072 Posts
I'm thinking when I ran 11.90's my mph was only about 101. I'd expect a mid 9 second pass at 138 mph, does that seem about right to everyone else?
No, it's totally out of whack; but your 11.90 at 101 is out there too--11.90 should be about 113....138 should be 9.70's
 

·
Registered
Joined
·
63 Posts
Discussion Starter · #15 ·
Any chip makes it stall at 3200? Lets say even a 2800 or 3000 chip? (how low do they go?)

Obviously if the converter only stalls at 3200 then no chip above that will make it stall higher. If the 3000 rpm chip makes it stall to 3000, I'd say it has to be in the converter.

138 mph does seem awfully high for a high 11 second car. I'm thinking when I ran 11.90's my mph was only about 101. I'd expect a mid 9 second pass at 138 mph, does that seem about right to everyone else?
He's telling me that with or without a chip = 3200. The converter has been sent back / checked, and tried a totally different converter = same thing. In reference to the mph, when the car launches, looks like it is in second gear, then wakes up right out the gate.
 

·
Registered
Joined
·
1,272 Posts
How high does it go on the foot brake. What does the converter flash to on the launch? What is the converter supposed to be rated at? It sounds to me like it's the converter as stated earlier.
 
1 - 18 of 18 Posts
Top