Chevy Nova Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
99 Posts
Discussion Starter #1
I built my engine and it was leaking from what it seemed to be behind the driver side head. I changed to permatourqe head gaskets and even switched heads around and the leak still exists. I am officially stumped. Along with the head gaskets there are new intake gaskets and new valve cover gaskets. Please help.
 

·
Registered
Joined
·
488 Posts
Did you check the oil pressure switch? Under the top right corner of the driver side head there's a plug on the block. Make sure it's not leaking from there. You could always get the UV Dye kit and check it that way.
 

·
Registered
Joined
·
3,849 Posts
Did you check the oil pressure switch? Under the top right corner of the driver side head there's a plug on the block. Make sure it's not leaking from there. You could always get the UV Dye kit and check it that way.
Good point, the sender is back there. JR
 

·
Premium Member
Joined
·
8,405 Posts
Quit guessing and use fluorescent leak check dye.
 

·
Registered
Joined
·
99 Posts
Discussion Starter #7
the only oil port on my block is the one right behind the distributor, unless I'm retarded but it isn't leaking from there. i can't find one behind the head, if someone could show me a pic that would be sweet. Thanks for your help
 

·
Registered
Joined
·
203 Posts
im sure its from that hole behind the head, as pictured, as I was priming my engine it started leaking oil from there also.
 
1 - 10 of 10 Posts
Top