Chevy Nova Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Need help fellas with my new Covan Classic Wiring Harness for my 66 Nova. The directions and pictures have to be the worst I have ever seen from anyone. Can anybody help me with this wiring nightmare? Send pictures or wiring layout please!!

Thanks Novados
 

·
Registered
Joined
·
56 Posts
Need help fellas with my new Covan Classic Wiring Harness for my 66 Nova. The directions and pictures have to be the worst I have ever seen from anyone. Can anybody help me with this wiring nightmare? Send pictures or wiring layout please!!

Thanks Novados
I agree 100%. I just put one of their setups in my uncle's 65 Nova the instructions are a complete JOKE. I have called several times with problems, and I have been put on hold for 10-15 minutes at a time while they try to find somebody that knows whats going on, but when I do speak to someone, they are lost too. I had to take the entire harness out, send it to american autowire for a problem with the fuel gauge wiring, and when I got it back, I put it back in and it still doesn't work. I'm trying to figure out the speedo wiring to the sending unit right now. I have it wired correctly according to what they told me but it still doesn't work. I called autometer to verify I was doing the calibration procedure correctly and I was so, they said its something wrong with the wiring harness......an answer I knew was coming unfortunately.

My advice is to get a factory wiring diagram to go along with their junk diagram, and feel your way though it slooooowly. It took me about a week of solid work just to get most of the stuff working. I have two things left to fix, the speedo and the fuel gauge, and I'll be done. I know I won't be using any more of their products. :mad: Sorry for venting in your thread, but it looks like your having the same problems I did.

what exactly do you need help with as of right now? I can try my best to help you out.
 

·
Premium Member
Joined
·
278 Posts
...My advice is to get a factory wiring diagram to go along with their junk diagram, and feel your way though it slooooowly. ...
I put one in my '67, with the exception of the speedo, which I can't test right now, it went pretty smooth. All gauges work, and worked the first time.

I agree, get the factory manual - makes it a LOT easier to figure out what you're wiring what to. I don't think I could have done mine without it, and I can figure out wiring pretty easily.

Let me know what you need...
 
1 - 3 of 3 Posts
Top