Chevy Nova Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
Hi,

I purchased a CBR power R&P w/ lower control arm upgrade last year. Love it for good control and response. The problem is when cold and high idle the power steering at a stand still moves easy back and forth. After driving for a bit the steering at stand still is very hard after half a turn of the steering wheel and hear the pump groaning with the same RPM. I have a new rebuilt power steering pump from C2O for a 63 Nova. Is the pump enough for the R&P? Is the pump failing? Am I expecting too much from the R&P? Please help
The CBR sway bar does not stay centered. I center the sway bar, take a drive and find the sway bar pulled to the passenger side. The only thing that stops the bar is the curve of the bar ending up in the fwd mount. The links are the same length with no modifications to the unit.
I like this forum and have solved a few of my issues from somebody else same issue.

Thanks!!

Richard
 

·
Vendor
Joined
·
4,056 Posts
Hi Richard,

It sounds like you have a pump issue. Due to the tight spacing and a large bar we can not put a locating ring in the sway bar as it will rub on the frame plate. How much does it move? Our cars have the same set up with any issues.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #3
The sway bars curve stops into the fwd mount. It canot move any further. It moves to the passenger side. The link on the pass side is 12 o' clock and the drivers is 10:45 position. The links are the same length and I start off centered with the links at 11:00 ( drivers side ) & 1:00 ( pass side).
Thanks on the pump info. I had a bad feeling it may be going out.

Richard
 
1 - 3 of 3 Posts
Top