Chevy Nova Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter #1
After about 1 week of not running, I finally finished puttting on the new manifold, 4 barrel 600cfm edelbrock carb, and HEI distributor. So I was driving with my brother and we pull up to a left hand turn lane and it DIES!!!!! So we pushed it to the side of the road and looked at it. The only way it would start was if I held the pedal to the floor for a while until it started. But then it would slowly bog down and die again. I think it is the second choke? I can keep the car alive by giving it gas so I have to hold the brake and give it gas to keep it alive at stoplights. What do you guys think this is? My second choke on the back barrels? Or what? It doesnt smell like its running rich, but I dont think its running with too much air.

Anyone have any ideas? A weeks worth of work and my car not working is really depressing :(.
 

·
Premium Member
Joined
·
1,924 Posts
I am thinking along the lines of low fuel pressure, possibly caused by being out of gas, float level out of adjustment, clogged fuel filter, or kinked fuel line. Try disconnecting the fuel line from the carb inserting it into a container and have someone crank the engine. You should get a pretty good squirt out of it once for every rotation of the engine. If not, start working your way back towards the gas tank eliminating obstructions or devices (lines, filters, pump, etc.)

By the way, the "second choke" is not really a choke, it is an air door and will not open until the accelerator is pushed down far enough and the engine draws enough air to need it to open. The choke covers the front 2 barrels on the carb and should be uncovered once the engine starts and warms.
 

·
Registered
Joined
·
96 Posts
I agree with the above especially if you just put the carb in...I went through the same thing when I bought my street avenger. Even though the box says it's a bolt on an go doesn't mean it is...you still have to go through the process of tuning it to your rides liking. Good luck it's a PAIN in the a$$ to get it just right.:D My problem was the floats and the mixture but once I got that set it ran like a champ again.:cool:
 

·
Registered
Joined
·
76 Posts
Discussion Starter #4
okay well this morning it started up. But when the car is running a lot of gas is leaking out of the throtle shaft thing. Anyone have a clue whats wrong with it :( ?
 
1 - 5 of 5 Posts
Top