Chevy Nova Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter #1
My car has been running fine since i got it all put back together and tuned. Today i took it out and as i was pulling into my driveway there was load popping coming from the engine. upon further investigation, it is coming from the carb. the car starts right up with no problems, but the more gas you put to it, the more popping the carb does. Also, there is no power, i couldnt even get it up the driveway while it was doing this. Cant seem to figure out why it is doing this. Any suggestions?
 

·
Registered
Joined
·
20,109 Posts
Cam going flat, pushrod off, wet ignition. Sounds like intake valve is perhaps staying open. Check ignition first as it's easy, make sure it's not wet. Pull valve cover and do a visual on valvetrain. Get someone to bump engine over with iginition disabled(coil wire off) and make sure all rockers are coming up the same distance. Good luck with it.
 

·
Registered
Joined
·
290 Posts
yes it could be the cam has wiped a lobe or two, did you touch the rockers to help promote wiping cam, i notice you said you had no power valve well put one in it then try ajusting your air fuel, do this with car warmed up turn clock wise til engine trys to stall the go counter clock wise 1 and a half to two turns on each screw, not enough fuel will cause popping also, good luck hope that works for you..
 

·
Registered
Joined
·
63 Posts
Discussion Starter #6
I tried adjusting the air fuel already, that didnt work. I dont drive the car very often, maybe once a week if that. I am wondering if it might be a fuel problem. I am going to pull the top ov the carb off tomorrow and check that alone with the valve covers.
 

·
Registered
Joined
·
1,896 Posts
as they all stated check to make sure you have not wiped a lope off the cam.

I did that once and it sounded like a machine gun going off.

When you know that you have all lobes good then go and recheck your valve tightness. I ended up having 4 valves too tight and caused my motor to pop like that
 

·
Registered
Joined
·
1,602 Posts
As everyone has said,pull a valve cover off and watch the rockers. My years on the bench have taught me that 'Carb popping' sound is a bad camshaft.:yes:Just my 2cents.
 

·
Registered
Joined
·
63 Posts
Discussion Starter #9
I did find a problem. The fuel filter was clogged. I am still going to take the covers off to check the rockers, but it has been raining here over the past few days and I don't have a garage to pull it into at the moment. Thanks for all the ideas everyone, I greatly appreciate it.
 
1 - 9 of 9 Posts
Top