Chevy Nova Forum banner

1 - 20 of 27 Posts

·
Registered
Joined
·
930 Posts
Discussion Starter #1 (Edited)
im having problems with my motor burning some magor fuel. We did the cam break in tonight and the thing burned up 10 gallons of e85 in 30 min :eek:. Im running a mallory comp 140 pump with a "deadhead" regulator, no return line. Carb is a 750 holley hp alcohol with quickfuel e85 metering blocks. Im running 90/96 jets. right now the idle mixture screws are backed out 1.5 turns for a starting point because I havnt had a chance to adjust it yet. What would be causing it to burn this much fuel? would running no return line have anything to do with it? would jetting it down to say 85 in the primarys help?
 

·
Registered
Joined
·
508 Posts
The e85 is like alky as far as using more fuel than gas. I know alky/gas is like 2-3 to 1. Dose the motor run fine? Are you having any problems with anything? And did you double check it make sure you wernt leaking anything?the e 85 will avaperate quikly so is it possible you could have been loosing it somewhere else?
 

·
Registered
Joined
·
930 Posts
Discussion Starter #7
o yeah it is.went to start up the motor again today and now it has vapor lock :mad:. pulled the #4 and #8 plugs and the number 4 plug had alot of fuel on it and when I pulled the number 8 fuel just gushed out. The thing is running crazy rich. heres a pic of the number 8 plug
 

·
Registered
Joined
·
508 Posts
If its getting that much fuel in the motor than there is something wrong with the carb. The way you set it up from an alky carb, is that what they recomended? Sounds like the carb is flowing alot more fuel through the boosters than it should be. If possible i would try another carb. The metering from alky to the e85 is differant im sure but not sure how much. Good luck!
 

·
Premium Member
Joined
·
11,072 Posts
when I pulled the number 8 fuel just gushed out.
How high is the fuel pressure? Sounds like it's blowing past the needle and seat.
Keep running it like that and you'll be pulling the engine for new rings next week! Check your oil and see how much fuel is in the pan.
 

·
Registered
Joined
·
930 Posts
Discussion Starter #10
when we were breaking it in my dad said it was running at 6 psi. I think im gonna order a new regulator and return line and different jets and try it with that
 

·
Registered
Joined
·
222 Posts
Sounds like your floats are to high or the needle and seats arn't shutting off. Check your float level and pull the needle and seats out and spray inside them with wd-40. There maybe something stuck in the seat and the wd might clean it out.
 

·
Premium Member
Joined
·
11,072 Posts
I think it has to do with me not running a return line
What about the thousands of cars out there without return lines--are they all having a problem? You have a problem with fuel getting past the bowls and into the engine. Jetting isn't going to change that and neither will a return line. Did you change the needle and seat assembly to use E85? The tips of the standard needles will be destroyed by alcohol.
 

·
Registered
Joined
·
930 Posts
Discussion Starter #17
I was sitting in the car while breaking it in but my dad said it was putting out quite a bit of fuel. Im not sure if it was coming out of the boosters or not because I havnt looked down it while running. I havnt started it back up since it was broken in. I havnt had a chance to see what vacuum it is putting out because I havnt let it idle yet but I do have a 5.5 power valve in it
 

·
Registered
Joined
·
508 Posts
if your geting fuel flow that is visible in the main body (from the boosters) than you need to check the float levels. sounds like they might be to high, and double check that needle and seat.
 

·
Premium Member
Joined
·
1,342 Posts
1 mile per gallon.....HELL YEAH!!!!:devil:
 

·
Registered
Joined
·
930 Posts
Discussion Starter #20
well I ordered a new mallory regulator and a 6an return line and another set of jets. Ill switch to 85/95 jets, switch out the needle and seat and adjust the float levels as soon as its back on the car. hopefully this will fix the problem.
 
1 - 20 of 27 Posts
Top