Chevy Nova Forum banner
1 - 6 of 6 Posts

·
Registered
1968 Chevy II Nova - 355 - 2spd Powerglide - Pro Street
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello all,

I am new to this forum, and just acquired a 1968 Chevy II about a month ago. The car was previously used as a drag set up.

Currently my brake lights/ turn signals in the rear do not work. When the headlights are on the tail lights / parking lamps do light up. However when the brake pedal is applied, no brake lights work. Also turn signals and hazards do not illuminate in the rear.

Have already checked the brake light switch, checked for bad grounds, blown fuses and replaced all bulbs front and rear. They turn signals / hazards and parking lamps are functional and work in the front of the car.

Upon looking further under the car in the rear. I noticed the driver side tailight socket yellow wire was cut and just hanging down. Same with passenger side dark green wire. I know these are the wires that make the brake / turn signal function.

My main issue is not knowing where I need to connect these wires back up to? Do they run all they way to the front panel (original) or connect elsewhere?

Any help would be appreciated.

Thanks!
 

·
Registered
1967 Nova SS
Joined
·
2,079 Posts
Check this link for various wiring diagrams.

 

·
Registered
1968 Chevy II Nova - 355 - 2spd Powerglide - Pro Street
Joined
·
3 Posts
Discussion Starter · #4 ·
Check this link for various wiring diagrams.

Awesome, thank you so much
 

·
Registered
1968 Chevy II Nova - 355 - 2spd Powerglide - Pro Street
Joined
·
3 Posts
Discussion Starter · #5 ·
1 - 6 of 6 Posts
Top