Chevy Nova Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
489 Posts
Discussion Starter #1 (Edited)
These are the standard shocks in the TCI clip. The top one is the bad one from the first pair, the middle and the bottom are the ones from the second pair. Is this just a bad batch because someone in the Monroe assembly line/quality control was on their smoke break? Are these ok to run? It's just a cruiser daily driver btw.



Sent from my ADR6300 using AutoGuide.Com Free App
 

·
Registered
Joined
·
489 Posts
Discussion Starter #2
Nobody?? Someone has to have some sort of opinion...

Sent from my ADR6300 using AutoGuide.Com Free App
 

·
Premium Member
Joined
·
1,568 Posts
Went thru 3 of their front struts assemblies in 15000 miles on my wife's car before we sold it, over a 2 year period. Same side each time. Don't know how the 4th one did.

On her 2008 Minivan I put on KYBs on the rear and it is great. I may be sticking with KYB.
 

·
Registered
Joined
·
489 Posts
Discussion Starter #5
only way i can see that area chipping or breaking is if the shocks were possibly bottomed/topped out...
I can see that...but these shocks are "brand new" Monroe shocks from right from the TCI package. I haven't even installed anything yet because I'm waiting to purchase the column. Chalk it up as a bad shock?
 

·
Registered
Joined
·
1,725 Posts
Does your front end have "Bump Stops" on it?
 

·
Registered
Joined
·
489 Posts
Discussion Starter #7
Does your front end have "Bump Stops" on it?
Nothing has been installed yet. These are right out of the box, brand new.
 
1 - 7 of 7 Posts
Top