Chevy Nova Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1 (Edited)
http://s975.photobucket.com/albums/ae240/emericks/?action=view&current=DSC01081.jpg


Couldn't find out why my engine wasn't running correct for over a year. Finally pulled off the carb and was going to check it out and possibly rebuild it. It was a brand new Holly 750 carb not even 2 years old. Just corroded as ****.

Has anybody seen this before? Anyway all this could have made its way into my engine? Or never would have made it through the squirters and what not?
 

·
Registered
Joined
·
1,908 Posts
The only time I seen any corrosion in a fuel system was at a little service garage I used to hang out at. The owner did all of the maintenance for the borough and he said there was an additive in the gas that was causing corrosion to the fuel system. Nothing that bad though.
 

·
Premium Member
Joined
·
1,563 Posts
Thats what a carb looks like running methanol when the carb hasn't been treated to run it.

Did you use any fuel additive "cleaners"?

There were reports that when gas went to $4 a gallon some added more than the %10 ethanol content. (It was cheaper than oil at the time) Problem is cars aren't designed for it. Just surmising.
 

·
Premium Member
Joined
·
15,966 Posts
Holley Carbs had a recall on carbs form internal corrosion.

Call Holley, might take a little firm talking.

They know about the problem.


AL


 

·
Registered
Joined
·
40 Posts
Discussion Starter #8
Nope, no cleaners ever. I will have to check for water.

Thanks Big Al. I will be calling them tomorrow to talk to them about it.
 
1 - 8 of 8 Posts
Top