Chevy Nova Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
487 Posts
Discussion Starter #1
I'm going to use a moroso pump with an ad on eletric motor to drive the pump. I would like to know if anyone else is useing this set up,and if so were are you mounting the alt and what brackets are you using. I also have heads with no bolt holes. Thanks, Ed
 

·
Registered
Joined
·
487 Posts
Discussion Starter #3
I don't have anything for the alt,will the low mount clear the frame? The engine is not in the car yet and and need to know what alt bracket set up to buy. Ed
 

·
Premium Member
Joined
·
11,208 Posts
I ran a Moroso motor on my 70 with a BB but used a long pump pulley on the bottom and mounted the alt in the origional position with the moroso motor on the drivers side at the top and it's still that way. It did require the heads to have the holes to mount it but a 70 did have them. I had to fab an adjuster bracket to tension the belt though. If you have no bolt holes in the heads I don't know about that. RM
 

·
Registered
Joined
·
487 Posts
Discussion Starter #6
I was thinking about running this set up but don't know if it will hit the frame. Ed
 

·
Premium Member
Joined
·
11,072 Posts
I was thinking about running this set up but don't know if it will hit the frame. Ed
That is similar to the one I use on my 69--It fits VERY snuggly between the block and frame. The belt selection is critical since there is about 1/2" of adjustment--you need one that is pretty tight when the alternator is loose so you can snug it up with the small movement available.
 

·
Premium Member
Joined
·
9,228 Posts
That's the same mount I use (B&M makes it). When I had the engine in the almost stock front end I believe it cleared but can't recall exactly. I'm now using a Chassisworks clip and everything clears fine.

 

·
Registered
Joined
·
34 Posts
Hey,Ed look up east coast Alt. They have a nice selection of brackets and Mini(I mean small!)Alt.I have one on my race car and it works great. Doug
 

·
Registered
Joined
·
34 Posts
Sorry... its actually EastCoast Electric.I run one of their one wire ultra Mini(the size of a softball)50 amp Nippondenso alt. it works great.They have complete kits-bolts-brackets and belt as well.
 

·
Premium Member
Joined
·
11,072 Posts
I run one of their one wire ultra Mini(the size of a softball)50 amp
If I had one of those my battery would be dead in a matter of minutes!!
My old 89 amp alternator was marginal--my 140 amp works just fine...electric water pump, electric fan(37amp draw), BG400 fuel pump, trans brake, line-loc, MSD 7AL-2+= WAY too much for a 50 amp toy alternator!!
 

·
Registered
Joined
·
34 Posts
Alt runs fine-two batteries-- Bg-400, Meziere water pump,electric cooling fan,trans brake,MSD 7AL-2,delay box,car has been [email protected] on Pump Gas
(Shaifroff ultra street 540 ci-781 HP)@3138 pounds,have put 11 runs on it in a day(track rental)yes put a small bat. charger on it for 15-20 min. between rounds but NOT required between every round-I have "hot laped this combo.This year more comp,much more cam and a Fogger set up in a 2450 pound car....and yes...Same alternator-I dont expect any problems-I would NOT run this combo on a street driven car with the same electris load.
Doug
 
1 - 13 of 13 Posts
Top