Chevy Nova Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
185 Posts
Discussion Starter #1
My 73' never had any ebrake cables on anything on it wen i bought it. I bought all 4 cables to get them working again (two out of the rear end, the middle cable and the front cable going to the foot part)...i heard theres a "hook" or sumthing in the setup of my 73' which i dont have...So can someone tell me what else is needed to get the ebrake to work on my car again and where i can find them...Thanks

Sean
 

·
Moderator
Joined
·
6,559 Posts
There is an "S" shaped bar that one end clips into a hole under the floor and the other to the cable. This bar directs the cable off of the floor cable with the threaded end over to the passenger side and then hold it more in line front to back while it goes to the right rear brake assembly.
The bar is maybe 6-8" long and about 3/16 or 1/4" in diameter. A person could possibly make one out of some round steel stock but you would have to do some measuring to see how long between the hook ends it actually needs to be.
I think the one hook end was in the hole under the floor on a floor brace but I would have to check. I don't think it went into the subframe but I'm going off of memory here.
If you cannot find one put the cables in the car and have the adjuster nut and U shaped clip off of the floor pedal cable coming out of the frame at the very end of that cable. This will give you the most adjustement to tighten the cable later. You can then measure what you need for the "S" shaped bar and make one.
Make sure the loop cable going from each rear wheel assembly is under the driveshaft.
I'll look later tonight at home and see if I have any pictures of that "S" shaped bar. I would think a 69-79 would work and it could be from another model besides the Nova (Omega, Ventura, Apollo, 74 GTO).
Jim
 

·
Registered
Joined
·
185 Posts
Discussion Starter #4
Looking at that diagram, i think i need alot more than i have. Anyone have a parts list of everything needed? Then i can really figure out wut i have to get ot make. Thanks

Sean
 

·
Moderator
Joined
·
6,559 Posts
Will this help ? :



From installing the system on my 68:


Jim
 
1 - 6 of 6 Posts
Top