Chevy Nova Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
Hi Everyone, As it turns out I have to replace my regulator and lower sash. I have the tape and ready to get things moving the only problem is I can figure out how to remove the locking remote rod.

I bought the Fisher catalog but don't see anything around this and didn't want to force it or break it.

Any suggestions on how to remove the long remote bar from both ends?
 

·
Registered
Joined
·
31 Posts
Discussion Starter #2
just to add more detail, in the manual it states the clip is spring loaded but there are no pics of this in the body service manual. So again, can't figure out out to disassemble the rod from the internal door handle to the door lock mechanism.

thanks in advance.
 

·
Registered
1965 Nova 2 Door Hardtop
Joined
·
119 Posts
On the regulator side, you have to unbolt the regulator from the door and then rotate the reg around slowly to line up the slot on the rod to the slot on the reg. On the latch side there is a spring loaded clip which you have to lift up on it and then slide it back a little. You can also unhook the reg side and remove the latch from the door to see how it is attached. Sorry no pictures.
 

·
Registered
Joined
·
373 Posts
Unbolt the assembly from the inner door structure and rotate it and you will be able to disconnect the rod and then pull the latch.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #5
thank you I just removed it. its like an extended horizontal slot that inserts it and rotated. I thought it was a spring clamp from what I read.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #6
just want to get my baby back up and running..

I just tried to replace the window tape but something didn't turn out right. Lubed it and all but it seemed to have slop. Wondering if it was from the soap but not sure.

The glass came back out fairly easy.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #7
just tried to retype my door glass but something didn't turn out right. Seemed like it had slop but not sure if it was from soap or not. It removed back out of the chase pretty easy. just want to get my baby back up and ready to enjoy. heres a pic...
 

·
Registered
Joined
·
31 Posts
Discussion Starter #10
btw, the tape I just tried to use is 1/16 I got from Classic. OER Part # GT0116

So not sure why there is slop

Also new lower chase channel from classic
 
1 - 10 of 10 Posts
Top