Chevy Nova Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
need some help
i have a 63 nova with NO TILT, the turn signal would not cancel after turning.
i bought he replacement turn signal switch that says 63 nova, shee-mar part #SM197

after i take it apart they look different, the one in the car matches pics i see online for 64-66 nova part # sm202
it has 7 wires, where the new one has 6 wires and looks a little different in design.
do i install new 6 wire? or should i get another one with 7 wire. i dont know if its the wrong one in there to start or the right one.
any thoughts
 

·
Registered
Joined
·
48 Posts
Discussion Starter #2
hey, also noticed the old one has
415688
one has the bearing in it , new one doesnt, so it seems my 63 does not have a 63 column?attached pic is one that matches what is in there
 

·
Premium Member
Joined
·
4,608 Posts
the one in the pic is the second version made mid year in '64 ( same as '65 ) , the bearing is reused in the new turn signal switch , the 7th wire is for the horn contact , it's attached to the bearing / horn contact apparatus and reused
 

·
Registered
Joined
·
48 Posts
Discussion Starter #4
the one in the pic is the second version made mid year in '64 ( same as '65 ) , the bearing is reused in the new turn signal switch , the 7th wire is for the horn contact , it's attached to the bearing / horn contact apparatus and reused
ok , i didnt see any horn apparatus, could i add it?
 

·
Premium Member
Joined
·
4,608 Posts
also anyone have any idea what the horn kit looks like or part #
check out your old switch it has a black wire going to the horn contact , its the brass contact around the outside of the bearing ,
 

·
Premium Member
Joined
·
4,608 Posts
I would post a pic of the bearing / horn contact , but I don't have a host to post pics to steve's
 
1 - 10 of 10 Posts
Top