Chevy Nova Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I have a problem with cracks in the forward rear spring mounts. I'm looking for suggestions on the best way to fix this. It has a mono spring. I have a 300 hp 350 with an automatic. It's an occasional driver but I'm woried I'll leave the differential on the road. Thanks in advance for any help.
 

·
Moderator
Joined
·
4,534 Posts
if it's the spring perches that are cracking you should put u-bolts on instead of studs.

Miles
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
I'll try and get some pictures tomorrow, The cracks are in the bracket where the front eye of the spring bolts to the frame.
 

·
Registered
Joined
·
1,799 Posts
Has anyone done anything to eliminate the great big washer used on that front spring eye mount? Got pics?
 

·
Vendor
Joined
·
7,085 Posts
I made a stepped washer and welded it into the large hole when I installed my Caltracs.I will post pictures when I get home from work.
 

·
Vendor
Joined
·
7,085 Posts


I machined a piece of 3/16 plate with a step in it so it fit snug in the large hole in the spring pocket and welded it in as best possible.
 

·
Registered
Joined
·
31 Posts
I've seen that done on about 10 or so novas. Works good. just make sure the bushing gets a squezzed too. so it holds tight! Wish they had a bushing to go in there with a hardened sleave like the 68 up cars do. so the bushings don't wear as fast and keeps the leaf springs off the frame!
 

·
Registered
Joined
·
7 Posts
Discussion Starter #13
Thanks for all the info. I'll get it welded up and try and fabricate a washer too. I tried to load photos using the info in the FAQ section but no luck getting it to work. I'll see if I can figure out another way.
 
1 - 14 of 14 Posts
Top