Chevy Nova Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
89 Posts
Discussion Starter #1 (Edited)
I recently bought a lokar throttle pedel and cable for my 63, the entire pedel moves when you press on it so i had to weld a rod under the bottom of the gold rod to reinfoce it towards the pedel, then i tried to get their hoky offset washer set up to work with a black cable and the cable broke because of the harsh angle into the valve cover, so i got a stainnless braided cable which bends a lot easyier but still doesnt work good because of the harsh angle , so i welded in a 9/16 deep socket to the firewall so i can put the cable in from the engine compartment and the cble gets to start bending a 1/2 inch before it hits the firewall not 3/4 inch after the firewall, and after all that i get WOT , but the cable looks like it is going to break and when i hook up my t.v cable it doesnt get WOT because of the resistance, so its only a matter of time before it breaks, i called them and told them their set up doesnt work and they said they havent got any complaints, yeah right! I just read about 10 posts that had all the same problems as me, i need to give them a link to the site and they also said they would have the engineer call me so i can show him what i did, which never happend, so after all that i am out $250.00 bucks and i am working on a new set up with a costom offset bracket and i am tring to get the cable more on a straight angle to the carb, but have to eliminate my wiper motor for it to work, LOL, their company is a joke, their carb bracket is also flimsy and i made my own with a holley bracket, i am pissed off and frusterated to say the least, but moving on!When i get it done and if it works good i will post some pics!If any one has pics of how they ran theirs and it gets WOT with a t.v cable hooked up lets see them!If you have had the same exprience as me please post so i can send it lokar so they cant deny that it sucks, or at least change their pakage to say this prouduct doesnt work good and we dont care instead of QUALITY plain and simple, LOL!
 

·
Premium Member
Joined
·
2,354 Posts
Smith Racecars is the only pedal to use on an early Nova. There are pics in amother post. I love mine. Dave
 

·
Registered
Joined
·
476 Posts
Yep I endured for about 5 years the same issues. I just sold mine on Ebay a few months ago. I wish they had the Smith Brothers out when I put mine in. We smoothed the firewall a few years ago so the Smith deal wouldn't work now anyway.
 

·
Super Moderator
Joined
·
9,776 Posts
X2 (X10?)

Same here. I'm still debating what to do. I used to have it set up with a modified 3rd gen pedal connected to the Lokar cable, then I switched to the Lokar pedal. Hate it, really disappointed. I don't know if I have the clearance to run the Smith Bros. or any solid style setup (plug wires are back there) so I may switch back to my old modified 3rd gen pedal with the cable.

Not looking forward to R&R'ing that stupid pivot bracket, I should have welded nuts on the engine side of it before I put the engine in.
 

·
Registered
Joined
·
810 Posts
Pat.

Our wires run down past the back of the heads by the pedal and it clears. You have to see one in person to understand just how much work they put into these and just how well they clear.

Look at the street one, not the race one

Joe
 

·
Premium Member
Joined
·
2,367 Posts
Tattoo, just sent a reply to your PM. I'm afraid I can't help since I still use the stock throttle linkage in my 67. There is definitely more resistance now with the TV cable, but I still get to WOT without any problem :devil:. From all the comments, I'm glad I didn't put a throttle cable in! :yes: good luck.
 

·
Registered
Joined
·
810 Posts
Tattoo, just sent a reply to your PM. I'm afraid I can't help since I still use the stock throttle linkage in my 67. There is definitely more resistance now with the TV cable, but I still get to WOT without any problem :devil:. From all the comments, I'm glad I didn't put a throttle cable in! :yes: good luck.

Found his PM and sent him this pic.

 

·
Registered
Joined
·
309 Posts
I have a stock throttle arm as well and I get full WOT too.in my nova and yes there is a bunch of resistance but i have successfully used LOKARs product too in my DADs 1965 Tempest wagon, pedal and braided cable and LOKARS TVcable I used BTO's cable in my NOVA
 

·
Registered
Joined
·
1,799 Posts
Can someone tell me the problems you are having with the stock 62-67 set-up? That is what I am using, and I really haven't found any good reason to go with a cable. Just wondering why so many get rid of the stock stuff? :confused:
 

·
Premium Member
Joined
·
1,348 Posts
I was considering a cable due to the fact that I am unable to obtain full WOT.. The bottom of the stock set up is hitting the back of the driver side head. This is not allowing the throttle arm to fully articulate. Not sure if anyone else is having this problem or not.
 

·
Registered
Joined
·
199 Posts
63 64 throttle cable

I use S-10 late 90's pedal comes with cable cheap, works fine on my 64 and 63 end of cable snaps in carb bracket with TV cable for 700r4
 

·
Premium Member
Joined
·
2,367 Posts
Chuck, here are some pics of my setup w/ TV cable for my 200-4R. You can see the bracket was modified slightly to clear the throttle rod. I checked the throttle blades with the pedal to the floor and they are very close WOT. It will only take about 0.1" adjustment to get there, and I will do that and reroute the plug wires this weekend b4 I take it to Irwindale :D.







 

·
Registered
Joined
·
24 Posts
Smith Racecraft

I tried the Lokar junk and found it for about two weeks, ripped it all out and shipped it back to Jeg's for refund (Thanks Jeg's!). Hated to pay the money but went with the Smith Racecraft kit and it absolutely rules. Ask for Andy there, he'll get you what you need.
The only issue I am having is you really have to lift to get all the way off the pedal. Just tipping your foot back like you've done all your life isn't good enough - the range of travel of the pedal is so much greater. Takes a little getting used to but will absolutely cure any throttle linkage problems you may have.
 
1 - 17 of 17 Posts
Top