Chevy Nova Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
ok here we go. I have owned this nova for about 3 years, its been in the garage since I bought it. Well I know have at a friends shop where its been strip of all paint, engine and electrical. I will try to keep everyone posted.












 

·
Premium Member
Joined
·
2,220 Posts
Thanks. It's from checkered racing. The only thing I don't like about it is the lack of instructions that came with it. And all the fab work it needs. If I had to do it over I might have gone with a little more expensive unit that needed less fab work. A true bolt in. That would have been an easier route for me, personaly. If you have access to a welder, and know how to weld, then this is a great suspension setup. And at a very good price.
Do a search on Checkered Racing. There are a few others on here that are using this front end. http://www.checkeredracing.com/
Good luck on your project. Keep us posted.
 

·
Premium Member
Joined
·
127 Posts
62?

Isn't that a 63?
My wagon is a 63 and it has the same grill & orange signals.
My son has a 62 sedan and it don't look like that and clear signals.

Not makin a stink! just checkin!
:D
lol
 

·
Registered
Joined
·
723 Posts
Isn't that a 63?
My wagon is a 63 and it has the same grill & orange signals.
My son has a 62 sedan and it don't look like that and clear signals.

Not makin a stink! just checkin!
:D
lol
ditto, I have a 62 and that's not 62 signals or grill, the hood emblem is correct though.
 

·
Premium Member
Joined
·
1,754 Posts
the hood emblem is correct though.
I don't think the hood emblem is correct for 62'. I just bought a NOS front 62' Emblem and it doesn't have the "Chevrolet" Script as part of the emblem, it looks like the one in this 62' Ad.



I had the style with the "Chevrolet" script on it before and I thought when I got my NOS one that it was the wrong emblem, but it is indeed correct for 62'.



Maybe there's a split year on the emblems? To the original poster, sweet project!
 

·
Registered
Joined
·
723 Posts
I don't think the hood emblem is correct for 62'. I just bought a NOS front 62' Emblem and it doesn't have the "Chevrolet" Script as part of the emblem, it looks like the one in this 62' Ad.

I had the style with the "Chevrolet" script on it before and I thought when I got my NOS one that it was the wrong emblem, but it is indeed correct for 62'.

Maybe there's a split year on the emblems? To the original poster, sweet project!
how strange, my 62 has the "CHEVROLET" script as well as does the NOS hood emblem I have. I have never seen a hood emblem without it.:confused:
 

·
Premium Member
Joined
·
4,125 Posts
The hood badge is definitely not '63. The '63 piece goes across the entire width of the hood.
 

·
Premium Member
Joined
·
1,754 Posts
Used em both I guess.

62' chevy ad without the scrpit


Another 62' chevy ad with the other emblem that has the script


I never knew they used two different emblems, and I don't know why they did? Being that both the 62 Convertible ad, and the 62' coupe ad use the one without script, maybe the one without script's for 62' 400 models? Tman, sorry to derail your thread, it just struck me weird that two different front emblems were used in 62'.
 

·
Registered
Joined
·
107 Posts
Not the greatest pic, but it shows my dad and my 62 and 63 novas. You can see the different grille styles, parking lense colors, and our 62 has the Chevrolet script and is a 62 convert (yes they made 62 converts)

 

·
Registered
Joined
·
6,794 Posts
Nice car VooDoo! I don't know how I have never seen your car before. It looks great! (now back to our original program:D)
Ron
It was at Super Chevy Pomona in 2000, and didn't take it out much after that so here soon it will be like a new car when I go to local shows.
 
1 - 18 of 18 Posts
Top