Edelbrock Question - Chevy Nova Forum
Visit our sponsor, National Nostalgic Nova
 
Steve's Nova Site is an automotive enthusiast website dedicated to the 1962 - 1979 Chevrolet Nova, Chevy II and Acadian automobiles. We work together to preserve, restore, drive, show, race and provide fellowship for these classic cars. This is one of the best places to find information about parts, rebuilding, restoration and racing. This website is not affiliated with GM, General Motors or Chevrolet in any capacity.

Go Back   Chevy Nova Forum > Body, Chassis and Mechanical > Drivetrain & Performance


StevesNovaSite.com is the premier Chevrolet Nova Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 2nd-October-2019, 06:55 AM   #1
kimrobertson
(OP)
 
kimrobertson's Avatar

Title: Nova Guru
iTrader: (2)
Status: Offline
Join Date: Nov 2010
Location: Ephrata, PA
Nova(s): 79 Phoenix
Posts: 2,064
Edelbrock Question

I have an Edelbrock 1406 with 2 idle mixture screws in the front. When I adjust the idle mixture the idle speed will change when I turn the right screw but nothing happens at all when I turn the left screw. Is this right or does this indicate a problem?
__________________
350/Tremec 3650 5 Speed/3.73
  Reply With Quote
Sponsored Links
Advertisement
 
Old 2nd-October-2019, 11:54 AM   #2
chevydealer35

Title: Nova Junior Member
iTrader: (0)
Status: Offline
Join Date: Mar 2017
Location: South Carolina
Nova(s): 1973 SS HatchBack
Posts: 142
Edelbrock Question

I have that carb in a box in my garage. lol Mine was on my Nova when i bought it & someone removed the top to do something & reinstalled it incorrectly bending the hell out of one metering rod. bent so bad it hung up the float on that side. They are a good carb if you know what to do when tuning.
Now your case---1st pull out the idle mixture screws completely & use carb cleaner & compressed air to clean out idle passages.
2nd reinstall & set idle speed no higher than 550--600 rpm to make sure the throttle blades are not in the transfer slots yet.
3rd use a vacuum gauge to adjust mixture screws---this worked well for me . I've done carb work for 40 years so i set float levels ---bought the Edelbrock kit with rods & jets & springs ---had a good time tuning. Mine was a 1406--mechanical secondary--electric choke unit. They work nicely if you use the 1405 chart to tune them with the different rods & jets. Much richer mixture.
Attached Images
 
  Reply With Quote
Old 2nd-October-2019, 02:52 PM   #3
kimrobertson
(OP)
 
kimrobertson's Avatar

Title: Nova Guru
iTrader: (2)
Status: Offline
Join Date: Nov 2010
Location: Ephrata, PA
Nova(s): 79 Phoenix
Posts: 2,064
Thanks chevydealer35... I had it working very nicely for months till I retarded the timing by 2 degrees...It idles fine but doesn't want to run smoothly with minimal load (I assume too lean). For example at 1900 rpm in 3rd at 25 mph, it lurches back and forth.(looks like I don't know how to drive ) Light throttle to WOT it's fine.

When I read your response I had actually just taken the left adjustment screw out and cleaned it. I shot carb cleaner in too everywhere else I could find a hole. Then I was able to get a response on adjusting the left screw... It is a little better but definitely still there.

Weird how this issue just showed up when I changed timing from 11 degrees advanced to 9 degrees (currently back to 10 degrees) without doing anything else. I did have carb apart 2 years ago--adjusted floats, cleaned real well. I also have the calibration kit and have played with the springs and metering rods and jets too to get it the best overall performance. But the metering rods and springs only impact throttle response and mixture under acceleration I think.

Oh, I also put a bottle of carb cleaner in the gas tank and have mostly pure (non-ethanol) in it now.

Maybe my issue isn't the idle circuit
__________________
350/Tremec 3650 5 Speed/3.73

Last edited by kimrobertson; 2nd-October-2019 at 02:54 PM.
  Reply With Quote
 
Old 2nd-October-2019, 05:34 PM   #4
kimrobertson
(OP)
 
kimrobertson's Avatar

Title: Nova Guru
iTrader: (2)
Status: Offline
Join Date: Nov 2010
Location: Ephrata, PA
Nova(s): 79 Phoenix
Posts: 2,064
Quote:
Originally Posted by chevydealer35 View Post
Now your case---1st pull out the idle mixture screws completely & use carb cleaner & compressed air to clean out idle passages.
How much air pressure would you recommend for this?

Also, reading through the Edelbrock owners manual...seems like I need to choose a richer combination metering rod/jet. I will try a combination that will richen it at low to moderate throttle.
__________________
350/Tremec 3650 5 Speed/3.73
  Reply With Quote
Old 3rd-October-2019, 12:50 PM   #5
chevydealer35

Title: Nova Junior Member
iTrader: (0)
Status: Offline
Join Date: Mar 2017
Location: South Carolina
Nova(s): 1973 SS HatchBack
Posts: 142
Edelbrock Question

Quote:
Originally Posted by kimrobertson View Post
How much air pressure would you recommend for this?

Also, reading through the Edelbrock owners manual...seems like I need to choose a richer combination metering rod/jet. I will try a combination that will richen it at low to moderate throttle.
I use a rubber tip blow nozzle with my air compressor---the blow gun will limit the pressure for you ---unless you drilled it out .
Use the 1405 chart in the paperwork that came with the tuning kit---the 1406 chart is not rich enough.
  Reply With Quote
Old 3rd-October-2019, 02:39 PM   #6
kimrobertson
(OP)
 
kimrobertson's Avatar

Title: Nova Guru
iTrader: (2)
Status: Offline
Join Date: Nov 2010
Location: Ephrata, PA
Nova(s): 79 Phoenix
Posts: 2,064
ok- Thanks for the tip re the 1405 chart... I can regulate my air pressure so I think I will keep it on the lower side.
__________________
350/Tremec 3650 5 Speed/3.73
  Reply With Quote
Old 9th-October-2019, 11:32 AM   #7
kimrobertson
(OP)
 
kimrobertson's Avatar

Title: Nova Guru
iTrader: (2)
Status: Offline
Join Date: Nov 2010
Location: Ephrata, PA
Nova(s): 79 Phoenix
Posts: 2,064
Found the problem! I had mismatched metering rods. I had mis-read the tiny numbers and had a 7347 and a 7342 in. I switched to both 7342s and that solved the problem. The 7342s being smaller helped richen the mixture which was too lean on light throttle just off cruise.

Thanks chevydealer35 for the help. BTW nice looking engine! Where did you get your alternator bracket?
__________________
350/Tremec 3650 5 Speed/3.73

Last edited by kimrobertson; 9th-October-2019 at 11:53 AM.
  Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Site best viewed set to 1024 x 768.

All times are GMT -4. The time now is 04:01 AM.

Custom Designed for Steve's Nova Site by: vBSkinworks

 
Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Lt
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.